Jump to content

Dead Power Button-How to flash new rom?

Guest brunomcf

Recommended Posts

Guest brunomcf

Hey guys!


I have a ZTE Grand X V970 aka TMN Smart A18 in Portugal (Mediatek processor), and the power button has stopped working after having it in my car, bumping from one side to the other on curves.


I've been ussing the Tap Tap App to unlock the screen which is fine so far. But the problem is I have a poor Rom installed with it, and can't event get a GPS signal.


I have tried to flash Carliv Recovery with MobileUncle Tools so I can install another Rom without having to use the Power Button, but once it boots into recovery after ZTE logo shows up, phone turns off.

Tried many times t get into Recovery, but it just won't do it.


I gotta say as well that I have recently flashed this last Rom using the Android definitions options, and not through the Recovery. I think that can be the problem.

Phone also does not install APK's from sdcard, I can only install apps from Play Store. I have all the checks on Mock Locations, USB debbuging, and so on. Even on Google Definitions app I uncheck "verify apps", that worked last time with the Rom and specific problem.


Can anyone help me?


Thanks from Portugal :)

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.