Jump to content

[DEV][ROM][24.4.] CyanogenMod 12.1 (Android 5.1.1) for ZTE Open C / Kis 3


Guest KonstaT
 Share

Recommended Posts

Guest scipilev

I wanted to thank you for your good work. I take a long time and are very pleased with the thank you . But there is a big problem , while waiting for an incoming call , a long time coming out of sleep , that is, the melody is played and the screen does not light up . How can this be solved? That log:

logcat_and_device_info.zip

Link to comment
Share on other sites

Guest KonstaT

After just replacing the kernel to the previous 5 days ago, my lookups are gone, not had a kernel panic any more.

 

More and more I think the lookups have something to to with the recent kernel changes.

No, I still don't have any reason to believe there's something in the recent ZTE updates causing this unless it's something that comes down hardware differences between devices or the stock firmware version that the device has before flashing CM (modem, bootloader, etc that stays intact flashing a custom ROM). Everything is fine on my device and I can't reproduce a freeze now even that I wanted to. :P I'm not going to revert any of the recent changes, hopefully we'll have logs (last_kmsg of the panic) with the next build.

 

Just passing by to say that I've been using the last build for about a week now and everything works perfectly on my french open c, good job and thanks a lot KonstaT. :)

One tiny thing though, when making phone calls the sound is a little too high, even at the lowest level. What can I do about it?

What, too loud?! Are you sure you're not hitting the volume boost button with your cheek or something? :P
 
In-call volume was just increased in the latest build (84->94). You can edit /system/etc/mixer_paths.xml and change the volume under handset path.

 

I wanted to thank you for your good work. I take a long time and are very pleased with the thank you . But there is a big problem , while waiting for an incoming call , a long time coming out of sleep , that is, the melody is played and the screen does not light up . How can this be solved? That log:

What do you consider a long time? For me it takes about 1-3 seconds max for the screen to wake on incoming call. Make sure you haven't covered your device's proximity sensor (if your device has one and make sure you get a proper reading from it too using e.g. CPU-Z) or the display will never wake up of course. My Open C doesn't have an ambient light/proximity sensor so I can't test if there's any issues related to this.
 
I can't see anything out of the ordinary in the logs. Theme you're using spits a lot of resource errors so have you tested this without using a theme? You shouldn't be using themes that don't support hdpi devices anyway (that theme is meant for xxhdpi/xxxhdpi devices).
 
You could also try disabling 'Phone number lookup' options under dialer settings. This is said to speed up dialer/incall UI on low end devices. Incall UI should already always stay on the memory so this is likely not related to low RAM.
Link to comment
Share on other sites

Guest KonstaT
New build. Please check if you see /proc/last_kmsg after (if?) you get a random reboot.
 
cm-12.1-20150520-UNOFFICIAL-KonstaKANG-kis3.zip
md5:0527c1e97841d254201b1eed5297b0b7
 
-disable dex2oat watchdog (large apps like Facebook, Play Services, etc can take over allowed 6 mins to dex2oat)
-disable 'Phone number lookup' options by default
-fix duplicate sdcard entries when importing/exporting contacts
-disable panic to download mode in kernel (should now reboot instead of freezing)
-patch CVE-2014-2523 and CVE-2014-9529 in kernel
Link to comment
Share on other sites

Guest Sergey76rus

Hello KonstaT
I have such problem. When I connect USB to the computer, my computer doesn't find my phone and I not as I can't copy music on phone from the computer. That I need to make that my computer found phone. Drivers are installed. I don't know as to deal with this problem :(

Link to comment
Share on other sites

Guest Sergey76rus

And isn't present, everything is good, I coped with one problem as there was another. When I am called at me the screen turns on only in seconds 5-10. How to correct it?

Link to comment
Share on other sites

Guest okmikel

Hello KonstaT

I have such problem. When I connect USB to the computer, my computer doesn't find my phone and I not as I can't copy music on phone from the computer. That I need to make that my computer found phone. Drivers are installed. I don't know as to deal with this problem :(

Same here, continuous fast change in connect and disconnect at status bar (icon for charging is on and off in change). Happend only when connected with a usb hub, tested with 2 differnt Windows PCs (work and home). Did not happen with kernel 3.4.0-g13ddc60 (04/23/2015), I was always charging at wok with the now not working usb port of my docking station. Direct link in laptop is still working.

Link to comment
Share on other sites

Guest KonstaT

Hello KonstaT

I have such problem. When I connect USB to the computer, my computer doesn't find my phone and I not as I can't copy music on phone from the computer. That I need to make that my computer found phone. Drivers are installed. I don't know as to deal with this problem :(

Settings -> Storage -> MENU -> USB computer connection. MTP/PTP/UMS all should work just fine.

 

And isn't present, everything is good, I coped with one problem as there was another. When I am called at me the screen turns on only in seconds 5-10. How to correct it?

Just answered this few posts up.

Link to comment
Share on other sites

Guest victormva_

New build. Please check if you see /proc/last_kmsg after (if?) you get a random reboot.

cm-12.1-20150520-UNOFFICIAL-KonstaKANG-kis3.zip

http://www.mediafire.com/?2c9knj8nyzzo3u9

md5:0527c1e97841d254201b1eed5297b0b7

-disable dex2oat watchdog (large apps like Facebook, Play Services, etc can take over allowed 6 mins to dex2oat)

-disable 'Phone number lookup' options by default

-fix duplicate sdcard entries when importing/exporting contacts

-disable panic to download mode in kernel (should now reboot instead of freezing)

-patch CVE-2014-2523 and CVE-2014-9529 in kernel

Now i can play games on 3d thanks for all!! This rom is amazing

Link to comment
Share on other sites

Guest webbe

Hi Konsta!

I have this on one phone, and 0506 on another.

 

I had problems with a previous one (perhaps 0423), it could hang when asleep.

This I have not notised yet on the later ones.

 

It works fine on my phones!

 

I noticed that UMS is working, but I have to connect to the computer first.

 

No problems sofar. I have not tried MMS, but....

 

Best regards/Webbe

Link to comment
Share on other sites

Guest micmon

Is gesture typing working for anyone, using the AOSP keyboard that ships with cm-12.1-20150520-UNOFFICIAL-KonstaKANG-kis3?

If so, what needs to be done to enable it (it is activated in my keyboard settings under "gesture typing")?

Link to comment
Share on other sites

Guest KonstaT

Is gesture typing working for anyone, using the AOSP keyboard that ships with cm-12.1-20150520-UNOFFICIAL-KonstaKANG-kis3?

If so, what needs to be done to enable it (it is activated in my keyboard settings under "gesture typing")?

You need to install gapps for the gesture typing to work. It depends on a proprietary library (libjni_latinimegoogle.so).

Link to comment
Share on other sites

Guest okmikel

MTP is working now, had to switch to mass storage and back to MTP and let winodws reinstall the driver (by manualy removing it from device manage).

 

Everything fine now and also no kernel panic since the new kernel from cm-12.1-20150520-UNOFFICIAL-KonstaKANG-kis3.zip.

 

Great work.

Link to comment
Share on other sites

Guest micmon

You need to install gapps for the gesture typing to work. It depends on a proprietary library (libjni_latinimegoogle.so).

I was afraid you would say this ;)

But thanks for the explanation!

Link to comment
Share on other sites

Guest KonstaT

I was afraid you would say this ;)

But thanks for the explanation!

You can just copy the one lib if you don't want to install the whole gapps...

Link to comment
Share on other sites

Guest fheusel

Hello, I've got cm-12.1-20150520-UNOFFICIAL-KonstaKANG-kis3 and recovery-twrp-2.8.5.0-kis3 installed on my ZTE Open C. The Partition Layout is the Kis3 one. Now I want to encrypt my device but every time I try my Open C just reboots. 

Link to comment
Share on other sites

Guest KonstaT

Hello, I've got cm-12.1-20150520-UNOFFICIAL-KonstaKANG-kis3 and recovery-twrp-2.8.5.0-kis3 installed on my ZTE Open C. The Partition Layout is the Kis3 one. Now I want to encrypt my device but every time I try my Open C just reboots. 

Logcat? I tested this working in early CM12 days but it's possible something has happened since. It might be a SELinux issue so audit log (/data/misc/audit/audit.log) would be needed too.
 
Both CWM and TWRP should leave required space for crypto footer but I've only tested this using CWM. Neither of the current recoveries support encrypted devices so you can't make/restore nandroid backups because your /data partition can't be mounted under recovery.
Link to comment
Share on other sites

Guest KonstaT

I'm using cm12.1 and have lag on my device, anyone have a backup cm 11 or 4.4 please give to me, thanks you

There shouldn't be any 'lags' compared to KitKat. In benchmarks Lollipop even performs slightly better. Make sure you've followed installation instructions in the third post and that you're using the correct gapps package for this Android version.
 
Erm, you restore nandroid backups that you've made yourself. Who would someone want to share their personal data with you? You'll find CM11 in the CM11 thread and stock ROMs in the stock ROMs thread (surprising, isn't it ;)). Again, follow the installation instructions!
Link to comment
Share on other sites

Guest micmon

You can just copy the one lib if you don't want to install the whole gapps...

 

I tried this now, this way:

 

$ adb root

restarting adbd as root

$ adb remount

remount succeeded

$ push libjni_latinimegoogle.so /system/lib/libjni_latinimegoogle.so

857 KB/s (624208 bytes in 0.710s)

$ adb reboot

 

Howerver the gesture typing still does not work. Anything else required? Can you point me to a known-good lib to make sure the one I got is not incompatible in some way?

Link to comment
Share on other sites

Guest KonstaT

I tried this now, this way:

 

$ adb root

restarting adbd as root

$ adb remount

remount succeeded

$ push libjni_latinimegoogle.so /system/lib/libjni_latinimegoogle.so

857 KB/s (624208 bytes in 0.710s)

$ adb reboot

 

Howerver the gesture typing still does not work. Anything else required? Can you point me to a known-good lib to make sure the one I got is not incompatible in some way?

You also need to set correct permissions (644) and reboot your device.
adb shell
su
mount -o rw,remount /system
chmod 644 /system/lib/libjni_latinime.so

Since you're insisting in doing this without a GUI. ;)

 
It's the lib from L-preview Google Keyboard 4.0.21003.1519572 that's the only one that works. Any Lollipop gapps should include the right one (might be just called libjni_latinime.so in some).
 
Edit. Correct name for the file is libjni_unbundled_latinimegoogle.so or you can just replace libjni_latinime.so. Either way should work.
Link to comment
Share on other sites

Guest micmon

 

It's the lib from L-preview Google Keyboard 4.0.21003.1519572 that's the only one that works. Any Lollipop gapps should include the right one (might be just called libjni_latinime.so in some).
 
Edit. Correct name for the file is libjni_unbundled_latinimegoogle.so or you can just replace libjni_latinime.so. Either way should work.

 

 

I took this lib: https://github.com/zyr3x/vendor_gapps/blob/master/proprietary/lib/libjni_unbundled_latinimegoogle.so

 

and copied it to /system/lib and rebooted. It has the correct name and permissions:

 

[email protected]:/ # ls -lisa /system/lib/libjni_unbundled_latinimegoogle.so                                            

   25026 -rw-r--r-- root     root       472636 2015-05-30 20:14 libjni_unbundled_latinimegoogle.so

 

But still it is not working :(

Link to comment
Share on other sites

Guest scipilev

 

What do you consider a long time? For me it takes about 1-3 seconds max for the screen to wake on incoming call. Make sure you haven't covered your device's proximity sensor (if your device has one and make sure you get a proper reading from it too using e.g. CPU-Z) or the display will never wake up of course. My Open C doesn't have an ambient light/proximity sensor so I can't test if there's any issues related to this.

 

I can't see anything out of the ordinary in the logs. Theme you're using spits a lot of resource errors so have you tested this without using a theme? You shouldn't be using themes that don't support hdpi devices anyway (that theme is meant for xxhdpi/xxxhdpi devices).

 

You could also try disabling 'Phone number lookup' options under dialer settings. This is said to speed up dialer/incall UI on low end devices. Incall UI should already always stay on the memory so this is likely not related to low RAM.

Link to comment
Share on other sites

Guest scipilev

Yes, this is the problem with not waking up was due to the proximity sensor . The screen lights up when both could seconds in 5 could in 10-15 , and could and did not wake up, even though he did not interfere , the screen is blank , there is no film . With its shutdown problem was gone , as was the second 1-3 . It can not be correct , so it is not necessary to disconnect the unit itself or with the sensor ? And on account of the fact I know I just experimented .

Link to comment
Share on other sites

Guest KonstaT

I took this lib: https://github.com/zyr3x/vendor_gapps/blob/master/proprietary/lib/libjni_unbundled_latinimegoogle.so

 

and copied it to /system/lib and rebooted. It has the correct name and permissions:

 

[email protected]:/ # ls -lisa /system/lib/libjni_unbundled_latinimegoogle.so                                            

   25026 -rw-r--r-- root     root       472636 2015-05-30 20:14 libjni_unbundled_latinimegoogle.so

 

But still it is not working :(

Because it's obviously the wrong file. That's for Android 4.3 (Jelly Bean) like it says in the commit and it's two years old anyway...

 

You need to use the specific one for Lollipop keyboard.

 

Yes, this is the problem with not waking up was due to the proximity sensor . The screen lights up when both could seconds in 5 could in 10-15 , and could and did not wake up, even though he did not interfere , the screen is blank , there is no film . With its shutdown problem was gone , as was the second 1-3 . It can not be correct , so it is not necessary to disconnect the unit itself or with the sensor ? And on account of the fact I know I just experimented .

I'm sorry, I can barely understand anything from that post. Have you actually verified that you don't get any reading from the proximity sensor? How long has this problem persisted? What was the last build it worked? Logs? Dmesg and audit log (/data/misc/audit/audit.log) for SELinux, please. Don't disable the sensor, lets rather fix it instead. I had some really cool stuff with ambient display planned for devices with proximity sensor in the next build.
 
Did it still work in cm-12.1-20150423-UNOFFICIAL-KonstaKANG-kis3 build (als/prox kernel driver was updated in cm-12.1-20150506-UNOFFICIAL-KonstaKANG-kis3)? There's changelog and previous build you could try available in the second post of this thread. Can you test if it works with this updated sensor HAL (just flash it in recovery)?
 
 
Like said, my Open C doesn't have ambient light/proximity sensor and every time I've made some relevant changes, I've asked feedback from the community. Unfortunately, I usually don't get anything in response. :(
Link to comment
Share on other sites

  • Guest unpinned this topic

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.