Jump to content

HUDL Bricked?


Guest GRAndroyds
 Share

Recommended Posts

My son has a HUDL (original) that had been rooted (via Kingo I believe.)

 

Due to some form of mis-match it hasn't been able to take any updates since the original one (back when the device was released.)

 

Somehow he managed to get into the recovery and did a 'Factory Reset' which has created a rather large problem:

 

As the HUDL reboots it has to go through initial setup.

 

Internet connection isn't optional (and even if you connect HUDL to the router but disconnect the router from the internet) it won't progress any further until it has a connection to the update server.

 

Once it talks to the update server it downloads and attempts to install the 1.3.x update. The trouble is that because of the non-stock bootloader (or recovery) that's been flashed the update fails.

 

Reboot and repeat adinfinitum.

 

Is there ANY way to break this cycle (pretty sure the Factory Reset probably disabled USB debugging) or is it now nothing more than an oversized paperweight?

 

Thanks for any help (whatever the answer is.)

 

Glyn

Edited by GRAndroyds
Link to comment
Share on other sites

IMO I would flash a ROM that already contains the latest update (v1.3.1).

I would anticipate that there are probably not going to be any further updates for a mark 1 HUDL so this shouldn't pose a problem in the future,

But, if you would like the possibility of being able to install any future updates should any be released then I would flash a completely STOCK ROM (no root etc).

 

anyhow, I have previously written a guide on how to flash a ROM using Windows 7 and provided 3 x variations for your flashing pleasure:-

 

I hope this helps

http://www.modaco.com/topic/372551-stock-hudl-rom-for-windows-rktools17-latest-available-rom-v131-build-jdq3920140424153851/

Link to comment
Share on other sites

Can't really add anything more, just follow link provided by sirius-c and you should be back up and running.

 

If you're concerned about future updates, you may wish to stay clear of custom recoveries. At least this way, any future (unlikely) Tesco OTA update for the original hudl1 will just install, but in the process remove the root (normal caveat applies - as long as you haven't removed anything any future OTA update checks for before applying the update).

 

It's all fun  :D

Link to comment
Share on other sites

  • 2 weeks later...

I've been enjoying and singing the praises of my hudl for 18 months but yesterday it only booted to Recovery system v4.2.41 - reboot and even wipe and factory reset (which appeared to work) only booted back to Recovery system. Since I live in France returning it for support to look at is not a very good option - so I am thinking is my hudl now just a doorstop as mentioned above or can I try and flash it better?

 

I am a Linux Mint user but have never tried rooting or flashing androids before. Having already spent hours reading threads I might be tempted to bin my hudl 1 and save up for a hudl 2.

Link to comment
Share on other sites

I find it interesting that even though you're suggesting it hasn't previously been rooted before - it would seem the system partition has gone belly up?

Is there any more background as to what's gone on prior to it starting not to boot normally?

Without additional info it's hard to balance up whether it's worth your potential learning pain to attempt to reflash your hudl via Linux - if you've newer done anything like this before. Others may well disagree but haven't so far been falling over themselves to offer help .......

Edited by Guest
Link to comment
Share on other sites

Thank you CaptainMidnight.

In recent months my hudl has been mainly serving as a tv media centre. It has been 24/7 connected to the hdmi and power leads. However, having been away, yesterday morning was the first time in 3-4 weeks that I had wanted to use it. Certainly nothing new installed (although maybe an unattended auto update) - perhaps the permanent power connection has cooked something?

 

I tried the LInux reflash yesterday - although never done that before - it seemed to flash without failing with errors. But when I tried to reboot I only got the Recovery options again. 

Link to comment
Share on other sites

Managed.to rescue my son's hudl (eventually) by digging out an old laptop, installing XP SP2 on it and flashing the (pre rooted with clockworkmod recovery) latest ROM to it (with rktools)

Thinking the most important part of the process was getting the WinXP32 setup.

Beg, borrow or steal (j/k) an XP system and give it a try.

Link to comment
Share on other sites

I do have my trusty eeepc which still has winxp - although it runs much better with mint 17 installed on a 32g sd card. However - I have decided to order a refurbished hudl 1 which should save me more hours of hassle - especially as I suspect my fault is likely to be battery and/or charging hardware rather than the system rom. Thanks again for help comments.  

Link to comment
Share on other sites

  • 8 months later...

for anyone that needs to know you can get to maskrom mode using rkflashtool and upgrade_tool on linux... for windows   androidflashtool

need a windows pc too unless u can use the update_tool

download helios rom links somewhere on this forum ill add it when i figure out how too!

link for bootloaders     >>>>>>   http://www.arctablet.com/blog/forum/firmware-development/rockchip-bootloader-collection-rk29xxloader-rk30xxloader-rk3168loader-rk3188loader/

you want the rk3188 loaders...ive had luck with the v1.04 (L) one

put hudl in loader mode..plug in to pc

cd to where you have youre tools installed

cd rktool

[email protected]:/rktool$ ./rkflashtool b 3

upgrade_tool

should list device as maskrom

 

unplug and take to a windows laptop

wipe ibd and install all the firmware.

reboot

 

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.