Jump to content

[ROM][5.1.1] F-AOSP [Y300/G510] [16/05/2015]


Guest fonz93
 Share

Recommended Posts

Guest farfix

Anyone has tested this ROM with a Y300-0151?  I know there was some 3G connectivity problems in 4.3 & 4.4 roms for this model (Something about the phone never conecting to 3G, probably due to kernel drivers)

@joseaguero2901 @alexandermb  you're both from venezuela, just like me; You would probably have this version of the Y300, how does 3G work?

 

I have an Y300-0151, and no issue with 3G in 4.4.x or 5.x.x...

Once I flashed the wrong firmware (0100), but then I found a method to "restore 3G in Latinamerica" in a spanish forum (HTCMania)...

Actually I'm trying SlimLP and no problem with connectivity (3G works fine)

 

 

@fonz... I think this is a stupid question, but... If I deodex the SlimLP, could I get Xposed working on that ROM? Or I need to do more changes in order to get Xposed working on 5.0.2? (It gave me bootloop when I tried to install via TWRP)

Link to comment
Share on other sites

Guest Catlish

I have an Y300-0151, and no issue with 3G in 4.4.x or 5.x.x...

 

pffff, I feel dumb now, I never flashed 4.4 cuz' of being afraid to loose 3G, and there was never shuch a problem.

Anyway, TY!

Just doing a nand backup now. Ready to flash

Link to comment
Share on other sites

Guest y0han17

I have an Y300-0151, and no issue with 3G in 4.4.x or 5.x.x...

Once I flashed the wrong firmware (0100), but then I found a method to "restore 3G in Latinamerica" in a spanish forum (HTCMania)...

Actually I'm trying SlimLP and no problem with connectivity (3G works fine)

@fonz... I think this is a stupid question, but... If I deodex the SlimLP, could I get Xposed working on that ROM? Or I need to do more changes in order to get Xposed working on 5.0.2? (It gave me bootloop when I tried to install via TWRP)

Xposed works correctly in SlimLP, I confirm it...You need only find the correct version, I forget which currently use in the past..sorry [emoji14]

Link to comment
Share on other sites

Guest creeper19

This modules working for now:

attachicon.gifScreenshot_2015-05-19-13-40-33.png

attachicon.gifScreenshot_2015-05-19-13-40-41.png

Flat style modules gave me bootloops on 2nd reboot, and sometimes camera says "Error..."

Edit: today i was testing how battery saver works with data on and din't got any blackscreen

as you have installed this ROM Xposed? I've tried and I get error. can you help me.
 
thanks in advance.
Link to comment
Share on other sites

Guest Catlish

Running nice. Dude, @fonz93 you weren't kidding, it took something like 12 min to boot after flashing.

 

I'm impressed how smooth lollipop runs on this little ol' device. Just, no words.

 

BTW, I got a weird graphics glitch when playing the lollipop easter egg, shame I didn't took a screen cap :S

 

I'll post any weird stuff I see. So far, awesome

Link to comment
Share on other sites

Guest pesartom

easter eggs is buggy (not that it matters!!!)

stock camera doesnt work, im using a 3rd party soft.

ive noticed that on AOSP roms (like this or AOSP mod), it gets laggy when im charging it.

i guess it has 20% more battery drain, havent tested accurately.

but really smooth

great job fonz

a funny fact is that i get 2 black screens every odd day since i flashed it, didnt get any on even days

Link to comment
Share on other sites

Guest alexandermb27

as you have installed this ROM Xposed? I've tried and I get error. can you help me.

thanks in advance.

Instal the alpha version vía recovery, then go to wipe dalvik and caché, and reboot, after that instal the alpha apk versión
Link to comment
Share on other sites

Guest Catlish

The ROM looks awesome so far.

 

I've experienced the 'black screen' problem. I belive its related to the cpu. I was doing a lot of stuff, switching between apps, installing from google play, etc. ant the phone just stopped moving. Pressed home key. screen got greyish. keep pressing soft buttons. screen got black.

 

I will try to have the cpu speed shown in the screen all the time and them I'm going to stress the system again, lets see what happens with the cpu speed during a blackout. I'll let you know on any news

Link to comment
Share on other sites

Guest fonz93

The ROM looks awesome so far.

 

I've experienced the 'black screen' problem. I belive its related to the cpu. I was doing a lot of stuff, switching between apps, installing from google play, etc. ant the phone just stopped moving. Pressed home key. screen got greyish. keep pressing soft buttons. screen got black.

 

I will try to have the cpu speed shown in the screen all the time and them I'm going to stress the system again, lets see what happens with the cpu speed during a blackout. I'll let you know on any news

 

That's not the black screen bug, read carefully the bug section, your problem is only a lack of RAM

Link to comment
Share on other sites

Guest cesartdavila

That's not the black screen bug, read carefully the bug section, your problem is only a lack of RAM

are there still problems with reproduction and recording with the camera or third-party applications as snapchat ? 

Link to comment
Share on other sites

Guest Catlish

That's not the black screen bug, read carefully the bug section, your problem is only a lack of RAM

 

Wait... just when resuming from sleep mode? That happened to my htc magic! It's a problem related to the cpu not resuming from deep sleep.

 

I am no dev, but I can tell you what was the problem then. Sometimes, when the magic entered sleep mode, the cpu speed was set at arrond 9 mhz. (no trouble here) the problem is this: if an app was in need of the CPU when it was idling at 9 mhz, the app just used the whole cpu power and freeze the device even making the cpu unable to speed up.

 

The device unfroze after the app was finished using the cpu, and then the cpu raized his speed to 414 mhz or whatsoever.

 

weird scenario. I think that's why @Lemon88 doesn't have this issue. He set the gov to keep the CPU at a relative high speed. and maybe he isn't using demanding apps.

 

Then, if @y0han17 is using the same cpu speed as @Lemon88, but he has apps using more cpu power than lemon, the problem showed there.

 

Just sayin, this is a hypothesis however.

Link to comment
Share on other sites

Guest Eriito

I tried the settings someone said. Interactive 480 row and its been 2 days without black screen. I have to say I'm impressed

Link to comment
Share on other sites

Guest fonz93

Wait... just when resuming from sleep mode? That happened to my htc magic! It's a problem related to the cpu not resuming from deep sleep.

 

I am no dev, but I can tell you what was the problem then. Sometimes, when the magic entered sleep mode, the cpu speed was set at arrond 9 mhz. (no trouble here) the problem is this: if an app was in need of the CPU when it was idling at 9 mhz, the app just used the whole cpu power and freeze the device even making the cpu unable to speed up.

 

The device unfroze after the app was finished using the cpu, and then the cpu raized his speed to 414 mhz or whatsoever.

 

weird scenario. I think that's why @Lemon88 doesn't have this issue. He set the gov to keep the CPU at a relative high speed. and maybe he isn't using demanding apps.

 

Then, if @y0han17 is using the same cpu speed as @Lemon88, but he has apps using more cpu power than lemon, the problem showed there.

 

Just sayin, this is a hypothesis however.

 

I don't really know if it's that the problem, i didn't get any black screen since i released the latest update and i use stock clock (it is also true that i use greenify and i run only whatsapp in background, but with the same use i was getting 2-3 black screens per day with the previous kernel), there are too many variables and one of them is that HTC magic got a really different hardware/kernel source, also, this problem wasn't there with PMEM and the old kernel source/adreno drivers that we used on KitKat, what i am trying to say is, we can't compare them unfortunately.

 

I'll wait for some more reports anyway, i suggest to all the peoples that got a black screen with the latest update, to increase their minimum frequency to 480 mhz, this is just for testing purpose, once you get the black screen (WAKE UP BUG ONLY, THIS MEANS THAT YOU HAVE TO REPORT THE BLACK SCREEN ONLY IF IT OCCURS WHILE WAKING UP THE PHONE FROM SLEEP, DON'T REPORT ANY OTHER CASES, THAT ARE PROBABLY DUE TO LACK OF RAM) you can report it here and go back to your precerences.

Link to comment
Share on other sites

Guest joseaguero2901

I don't really know if it's that the problem, i didn't get any black screen since i released the latest update and i use stock clock (it is also true that i use greenify and i run only whatsapp in background, but with the same use i was getting 2-3 black screens per day with the previous kernel), there are too many variables and one of them is that HTC magic got a really different hardware/kernel source, also, this problem wasn't there with PMEM and the old kernel source/adreno drivers that we used on KitKat, what i am trying to say is, we can't compare them unfortunately.

 

I'll wait for some more reports anyway, i suggest to all the peoples that got a black screen with the latest update, to increase their minimum frequency to 480 mhz, this is just for testing purpose, once you get the black screen (WAKE UP BUG ONLY, THIS MEANS THAT YOU HAVE TO REPORT THE BLACK SCREEN ONLY IF IT OCCURS WHILE WAKING UP THE PHONE FROM SLEEP, DON'T REPORT ANY OTHER CASES, THAT ARE PROBABLY DUE TO LACK OF RAM) you can report it here and go back to your precerences.

Fonz as you would to increase the frequency?

Link to comment
Share on other sites

Guest wbrambley

Question. Does anyone knows why the system always report battery charge as 3mV?

Decimal placing, should be 3.xxx volts. It's nothing new.
Link to comment
Share on other sites

Guest creeper19
hello, I have followed the tutorial and when lit after flash the zip file, I also clean the cache, and the Android logo not go through several restarts.
 
someone give me a solution?
 
thanks in advance and greetings
 
I edit
I'll try to reinstall the ROM from scratch with Xposed file.
Edited by creeper19
Link to comment
Share on other sites

Guest Catlish

Hey, I just made a new bootanimation. Using the OEM 4.1 huawei and the lollipop one.

 

You can do whatever you like. add it to the rom, make it flashable, etc. 

 

To install: 

How to flash:

 

- Are you really reading this?

 

/system/media

 

Works like a charm to me

 

https://www.dropbox.com/s/aracrzpwcvj78ni/bootanimation.zip?dl=0

 

Edit: This one looks correctly in our device, the resolution is 480x800

Edited by Catlish
Link to comment
Share on other sites

Guest fonz93

Hey, I just made a new bootanimation. Using the OEM 4.1 huawei and the lollipop one.

 

You can do whatever you like. add it to the rom, make it flashable, etc. 

 

To install: 

 

/system/media

 

Works like a charm to me

 

https://www.dropbox.com/s/aracrzpwcvj78ni/bootanimation.zip?dl=0

 

Edit: This one looks correctly in our device, the resolution is 480x800

 

 

PS: 

 

I forgot to include the fixed bootanimation, you can live with it until i release the next version or flash this: https://drive.google.com/file/d/0B-xonQbKq2U2ZUtjNmdLNHhIUFk/view?usp=sharing

 

Thanks but i personally like more the AOSP one

Edited by fonz93
Link to comment
Share on other sites

Guest Jairus1998

I made a bit of customization on bootanimation based on Aosp

 

What I've change is

frame-rate: 60fps

resolution: 391x238

size : 700kb+

 

It's smooth and cute because small.

 

EDIT:

 

This is not a flash zip. Please push this into your "/system/media"

 

Removed download link and apply attach files

bootanimation.zip

Edited by Jairus1998
Link to comment
Share on other sites

Guest fonz93

I made a bit of customization on bootanimation based on Aosp

 

What I've change is

frame-rate: 60fps

resolution: 391x238

 

It's smooth and cute because small.

 

Download link: https://mega.co.nz/#!i1FhiBaS!is8gLIvoKnP5oq-_ccFGdsb1_x7T3nTp0WQlq8VnPcs

 

EDIT:

 

This is not a flash zip. Please push this into your "/system/media"

 

It's similar to this: http://www.modaco.com/topic/375101-rom511-f-aosp-y300g510-16052015/?p=2257393

 

i didn't include any of them as our resolution is HDPI, and the HDPI one perfectly match our phone

Edited by fonz93
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.