Jump to content

Bypass forced lollipop update on setup wizard


Guest Huudl
 Share

Recommended Posts

I factory reset my (already rooted) device, which was running KitKat, and it was driving me insane how the hudl's setup wizard was forcing me to download and install the Lollipop update. I managed to find a way around it, and since I hadn't seen anyone post a method here on how to do that, I thought that I'd post it to help out anyone else in the same predicament.

NOTE: THIS REQUIRES YOUR DEVICE TO ALREADY BE ROOTED PRIOR TO FACTORY RESET (although maybe you can flash the rooted image file and then try this but I'm not sure)

 

CREDIT TO NORMOLA FOR THIS PART

Quote

 

Well, after some fiddling I've managed to find a way around the forced update for a first time install.

 

  1. First off, wipe the device from recovery.
  2. Boot up and select 'Add Network' from the wifi selection screen.
  3. Hold down the microphone key on the google keyboard and select the settings icon and select the settings icon.  This will show 'Input Options'.
  4. Select 'Google Keyboard Settings'
  5. Select 'About Google Keyboard'
  6. Select 'Open-source licences'
  7. Highlight some text with a long press then select 'WEB SEARCH' from the top right
  8. This will take you to the Google Now search page and show a not connected error.
  9. Type 'Settings' into the search box and select the settings page from the drop down.

 

From here you can enable developer mode, enable adb and fix any stupid changes to the system partition that you might have made (whoops :P )

 

There's probably a shorter route than this but I'm just pretty happy to have the chance to repair the damage :D

 

After this, you should be able to successfully enable "USB debugging" in "Developer options" which will allow you to use adb. Connect your hudl to your computer (make sure you have the ADB drivers installed), open command prompt, type in "adb devices" and a prompt should appear on your device asking you to confirm the debugging. Accept it.

Go back to the setup wizard and continue with it, up until the point where it informs you that there's a new update available - BUT DO NOT BEGIN THE DOWNLOAD.

Instead, inside command prompt type "adb shell" (make sure you have ADB tools installed) which will start a shell, and then elevate it to root using "su". A prompt from SuperSU should appear on your device, asking to allow root permissions for ADB shell - accept it.

Then in command prompt type "pm disable hudl.ota", the response should be "Package hudl.ota new state: disabled".

Then, you want to kill the process, to do this you must figure out its process id. Type in "ps | grep hudl.ota" which should return you information about the hudl.ota process. You want to read off the second value of the hudl.ota line, starting from the left (it's the number next to system). 

Once you have this id, type in "kill IDHERE" which should then close out of the new update available screen and take you to a screen where it says it's updating your apps. After that, the setup wizard will finish and you're free to use it.

As a side note, if you ever want to upgrade to Lollipop for some reason, then you will need to re-enable hudl.ota. To do this, just open a shell again and type in "pm enable hudl.ota".

Edited by Huudl
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...

*falls down and kisses your feet*

Fantastic! Solved all my problems - have rooted, prevented updates, used Titanium to delete all Tesco horrors.

Hudl2 is now rooted KitKat FOREVER . . . .

thanks again

Link to comment
Share on other sites

  • 1 month later...

I have a fresh hudl 2 to root. During the initial set-up, once connected to wifi and it searches for updates, will I be forced into having Lollipop installed because obviously I won't then be able to root it?

Thanks. 

Link to comment
Share on other sites

If you connect during initial setup I think it updates automatically so best bet is not to connect to WiFi until after initial setup - I think that's possible but you will have to do WiFi/Google account setup manually afterwards. Thereafter the update should be optional.

Two years since I set up a hudl though so don't take this as gospel!!!

Link to comment
Share on other sites

  • 1 month later...

It doesn't allow you to skip the wifi setup process now, i just factory restored my already rooted KK 4.4.2 hudl2 & it forced me to connect to wifi & tried to download lollipop which i stopped, followed the above process & it worked a treat.

My original post in this thread was aimed at people already on kk not wanting to update to lollipop via the normal ota method, not after doing a factory restore.

Link to comment
Share on other sites

  • 1 year later...

Here's the method I just used after going a bit crazy disabling apps and services after rooting my Hudl 2 on KK 4.4.2, and having the Hudl 2 no longer boot or go into the bootloader.

You will need : ADB / Fastboot tools (from the first post at the bottom)  ...and ADB Driver installer

Sorry, these instructions are fairly brief (if you read the first post in this thread and the first post on here, you will have everything I did)

 

  • Open a command prompt / terminal window to the location where you extracted the ADB fast boot files
  • Enter 'adb-windows reboot bootloader'
  • Select recovery
  • Go for wipe data factory wipe
  • Use the instructions at the top of this page ( Google Now search page etc), but search for Playstore instead of Settings.
  • It will ask you to setup wifi and a google account - that's ok, do it.
  • Install App Quarantine
  • Go into the App Quarantine settings > filters, and enable System Services
  • Unfortunately, you don't have a back button at this stage so you will have to reboot.
  • Reboot and use the method again ( Google Keyboard Settings >  About Google Keyboard > etc)
  • Search for App Quarantine, and quarantine "hudl updates" (you need to give it SU privileges, via the pop-up)
  • Reboot, and finish the setup (if Download Update is still there is hasn't worked - don't click it)

I hope this helps some random person. I tried killing the hudl.ota  process about 3 times and it didn't work for me.

 

 

Edited by Disposible Battery
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.