Jump to content

LeEco / LeTV Le1 - X600 - Info / Software / Custom Roms

Guest dakok

Recommended Posts

You did a smart move 

The last rom I flashed on Coolpad after F1 went to my better half was MIUI - and it was actually much better than I expected.

So I assume that the one that's already available and others that will come - will be more than appropriate replacement for

stock eUI rom. That might happen with AOSP, too.

Moreover, few days ago the only important thing that was missing from bobN MIUI rom is now available

as a separate app for flashing through TWRP recovery:

LeTV stock camera

Whats even better is that it offers an update after the first boot or later. 

Now we have the most interesting system apps available in custom rom or as a flashing package...


Link to comment
Share on other sites

Some interesting stuff:


Waking phone from coma - (source in Chinese, needs translation - something about OTG)

- bobN, Hanuma50 & Lepi did a fresh TWRP 3.0.0-0 - it seems to be working on x600 (fix if PC won't recognize phone in recovery mode)

- Vazarg will make a new MIUI release tomorrow (has the IR remote app now, too)

EDIT: might be this one: http://ceceg27.free.fr/LeTV-X600/MIUI7/LeTV_X600_MIUI7_6.2.18_vazarg_eu.zip (expect problems with MI account)


Latest MIUI 7 274 roms from China:


Miui 7 6.2.20 by Kaka

Link1   Link2 b8ab


Miui 7 6.2.19 by cnxinbo

Link  43a7



Link to comment
Share on other sites

15 hours ago, dakok said:

You did a smart move 

The last rom I flashed on Coolpad after F1 went to my better half was MIUI - and it was actually much better than I expected.

Hi dakok - sorry if this is off topic but which MIUI did you flash on the Coolpad F1?

Link to comment
Share on other sites

New stock release (11s) is up. 

TWRP flashable version with root and busybox; no gapps. It's almost stock, I haven't "decrappified" it thoroughly, just added mobileuncle and changed the baidu keyboard for a xperia material themed one




Edited by 77chedu
Link to comment
Share on other sites

Thanks 77chedu!


I need some help guys. :) Phone stuck in stock recovery.

Got 011s OTA update this morning but had to remove Kingroot for OTA to pass.

Switched off root in Kingroot then uninstalled the app.

OTA didn't pass and I'm stuck in stock recovery now. Every attempt to switch off the phone results in 

going back to recovery where I can't do anything since it won't use the update.

If I turn off the phone (holding power for 10s) it goes to stock recovery when

I connect it to PC or charger and the PC won't recognize it.

To leave it on until the battery drains?

Link to comment
Share on other sites

I did that but nothing seems to help

The only thing I get is whatever I do:

Phone boots, LeEco / Recovery screen is on


after a while, I get this


Any option I choose I get back to this again. If I hold power button for 10 seconds and turn it off it goees again to above screens when connected to PC or charger. Vol+ & Vol- & Power - The same thing, Vol- & Power - again that screen above.

The things I tried:

1. Drain battery to 0%

Phone is off but when I connect it to charger or PC it goes to that Recovery / Update screen after few minutes.

2. ADB - ADB Devices command - Nothing!

The only thing that happens when I connect it to PC is the USB sound and the phone goes to that Recovery / Update and nothing happens in device manager. I tried several TWRP recovery.bat tools but they don't see the phone.

3. SP Flash Tool

Turned the phone off and pressed Download, connected it to PC and



All drivers are 100% good since phone was fully recognized few days ago and I reinstalled them today again. :(

Link to comment
Share on other sites

I googled and found some LeTv/LeEco forum threads about unbricking in case they are of any use - but you have probably already found and tried these...?

Hopefully there is a way back from this situation.

Link to comment
Share on other sites


LeBrick solved!


Thanks to friendly forum members from LeTV Re, 4PDA, Telekineza and Modaco!


I think that the main thing that helped was FlashTool package with 002s rom from 4PDA (tnx bobN) 

and Download Only flashing that brought PMT Change error but stopped that PITA Recovery / Update screen.

That error required Firmware Upgrade flashing mode and I tried several FlashTools and Vol- or Vol+ holding combos that lead to:

Brom CMD Jump Da Fail 2035
Dram Fail 4032

That scared the sht out of me :(

In the end, the thing that did the job was FlashTool From Wandy Tools in Firmware Upgrade mode, without touching buttons, new cable and new USB slot with Type-C adapter on cable (probably non important but here it goes :) )


No more OTA updates and stock recovery, only the complete rom through TWRP.

Once bitten - twice shy. :smile:


Link to comment
Share on other sites

Not sure if any of the links that I provided helped but I'm delighted that you got it going again - and thanks for posting the info which may help others in the future.

Still waiting on my phone to be delivered so just keeping an eye on this thread.

Are you saying that stock ROM updates should be done via TWRP to avoid problems?

If so where do custom recovery zip versions of the ROM come from?

If this is covered elsewhere then just point me in the right direction... Thanks. 

Edited by dalyer
Link to comment
Share on other sites

Yes, TWRP is preferable for this phone. :)

I think the best one is from grossoshop and you can flash stock roms through it and keep the twrp...


Link to comment
Share on other sites

Thanks a lot.

I'll have a bit of reading to do before I mess with my x600 when I get it. 

The top post is really useful so thanks for collating all of that info.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.