Jump to content

[RECOVERY] TWRP 3.0.2-0 for Chuwi Vi10 Plus, Hi10 Plus, Hi10 Pro, Hibook & Hibook Pro


Guest KonstaT
 Share

Recommended Posts

1 hour ago, winnieyip said:

Thanks for your reply indeed. I am downloading but I have another question here - I believe I have installed the TWRP successfully but I failed to boot to that TWRP for the installation. Is there any hint for me?

The reason why I asked as I found that I encountered error when running the command "adb reboot recovery" at my Macbook when connecting the device using USB. I have no idea how to fiix

On 12/10/2016 at 11:29 AM, KonstaT said:

Just flash TWRP and allow it to modify system now that you've disabled dm-verity (IIRC there's a slider booting into TWRP or untick 'keep system untouched' box somewhere). There's a script (/system/bin/install-recovery.sh) that will overwrite TWRP with stock recovery on boot otherwise.

 

Link to comment
Share on other sites

hi everyone!! and Happy new year 
I have somethings problems with the steps for install CM13.
I start with the fastboot oem unlock, after, I install TWRP. When I reboot on TWRP the storage principal isnt recognized , 0mgb . For that I have to copy the "disable" in to external storage and after,  I try to install but the TWRP doesn´t make it and showes "mount unable data" and others mistakes.

I tried to do a reboot after to fastboot oem unlock , the sorprise was that I can reboot to TWRP and the storage internal is recognized and I can install the "disable" and the rom (cm13) but the gapps no, error 20, "the gapps is not  for 5.1.1" , that is to say, the TRWP doesnt install any zip 

the conclusion is that I can boot the TWRP but doesnt install any rom and I have to install by intel fash the rom android stock 

some help please

thank you 

PD Sorry for my English and my tablet is hibook pro

 

Edited by xicharito
Link to comment
Share on other sites

On 1/2/2017 at 8:40 PM, AKSU78 said:

Dear KonstaT.

Recently, new Hi10 Pro ( serial number of the begin with HQ64 ), they used a new touchscreen hardware. Old TWRP on them is not working properly. Can you help with the new TWRP?

http://forum.chuwi.com/thread-2341-1-1.html

Is not working how?

If that's really the case I'd also have create patches for CM12.1 & Remix OS ROMs. It also means dropping support for some Hi10 Pro devices with CM13.

7 hours ago, xicharito said:

hi everyone!! and Happy new year 
I have somethings problems with the steps for install CM13.
I start with the fastboot oem unlock, after, I install TWRP. When I reboot on TWRP the storage principal isnt recognized , 0mgb . For that I have to copy the "disable" in to external storage and after,  I try to install but the TWRP doesn´t make it and showes "mount unable data" and others mistakes.

I tried to do a reboot after to fastboot oem unlock , the sorprise was that I can reboot to TWRP and the storage internal is recognized and I can install the "disable" and the rom (cm13) but the gapps no, error 20, "the gapps is not  for 5.1.1" , that is to say, the TRWP doesnt install any zip 

the conclusion is that I can boot the TWRP but doesnt install any rom and I have to install by intel fash the rom android stock 

some help please

thank you 

PD Sorry for my English and my tablet is hibook pro

Have you encrypted your device? You need to format /data partition in that case (this will also erase internal sdcard so backup your files first).

Link to comment
Share on other sites

Have you encrypted your device? You need to format /data partition in that case (this will also erase internal sdcard so backup your files first).

No, that i know . How i can know if the tablet is encrypted?

Link to comment
Share on other sites

7 hours ago, AKSU78 said:

Touchscreen not working properly - shifted by half of the screen diagonally

Report the problem here: http://4pda.ru/forum/index.php?showtopic=769658&view=findpost&p=56719096

I've added TWRP and CM12.1 & Remix OS patches to my wonderfull new site. :) CM13 is not supported on this batch of Hi10 Pro (z8350 - serial no HQ64) devices because of hardware changes and lack of kernel source code.
http://konstakang.com/devices/chuwi_vi10plus/

There's already been a dm-verity patch and stock recovery for Hi10 Pro (z8350 - serial no HQ64) 20161208 firmware quite some time.

Link to comment
Share on other sites

  • 2 weeks later...

Hello. I have HQ64 and install CM12 on it.  I used this file : recovery-twrp3020-cht_cr_mrd_w-Hi10Pro-HQ64.img  and fastboot flash recovery command. Tablet responded but every time I try to enter recovery , it gives  me  red triangle on android robot.  So I simply  fastboot boot the file. I think TWRP was not flashed. Maybe I must use the second file:  

recovery-twrp-3.0.2-0-cht_cr_mrd_w-Hi10Pro-HQ64.zip ?

Link to comment
Share on other sites

Hi KonstaT, 

I currently have your older version of twrp 2.8.7.0 for Hi12 from Techtablet forum. It worked to install CM12.1 but would there be advantage to change to this version and which one to use as Hi12 is not listed. 

Link to comment
Share on other sites

Hi. I read all posts and I dont find a recovery for my Chuwi. I have Hi10 Pro - z8350 - serial no PQ64 . I dont know if I have use  "Hi10 Pro" or another.

Can you help me?

Edited by ElAnton
resaltar la p
Link to comment
Share on other sites

50 minutes ago, ElAnton said:

Hi. I read all posts and I dont find a recovery for my Chuwi. I have Hi10 Pro - z8350 - serial no PQ64 . I dont know if I have use  "Hi10 Pro" or another.

Can you help me?

You can use recovery-twrp3020-cht_cr_mrd_w-Hi10Pro.img/zip.

Link to comment
Share on other sites

  • 2 weeks later...

Hi @KonstaT I've bought another VI10 plus and flashed it with the Chuwi dual boot BIOS. I've installed stock Android and your TWRP, but TWRP can't mount /data for some reason. As a consequence I can't backup the existing installation, and if I install cm12.1 (after disabling dm-verify), the tablet won't boot Android and needs to be re-flashed with the Intel tool. Do you think I've missed something obvious or do you think it's a BIOS thing?

Thanks as always!

Edit: Apologies, Google was my friend! I have formatted the data partition and am now attempting to install again :)

Edited by BacktotheFuji
Forgetting that Google is helpful afterall :)
Link to comment
Share on other sites

On 09.12.2016 at 6:23 PM, opirsone said:

Hi I tried to install the TWRP recovery as described in the guide, I was able to see the TWRP menu, then I did a factory reset, now the tablet with the inscription CHUWI remains fixed to the boot, I tried to go into recovery but displays the recovery standard Android, does not show the TWRP recovery, also pc not load the drivers and recognizes the device as a tablet cherry trail cr, what can i do?

Hi,
I have the same issue.

My Chuwi HI 10 plus have z8350 and clean Android OS.

I have installed TWRP from here https://www.androidfilehost.com/?fid=457095661767101048,

Also installed boot image that disables dm-verity , got Root access as well.

Allowed  TWRP to modify system directory.

However when i try to reboot or boot to recovery i can't access TWRP and get to standard android recovery with android image in the centre of  the screen instead.

Tried many times to reinstall TWRP - there are no result.

Can some one to help me to properly install TWRP please?

Edited by Rammbock
Link to comment
Share on other sites

On 2/25/2017 at 2:53 PM, Rammbock said:

Allowed  TWRP to modify system directory.

That's the key. When you boot out of TWRP it will modify permissions on /system/bin/install-recovery.sh and prevent overwriting recovery partition with stock recovery on boot. You can also manually remove/rename that script after disabling dm-verity.

Edited by KonstaT
Link to comment
Share on other sites

In case you are searching for TWRP for Hi12:

Here you can find a file (see post #39842 on page 2)

https://techtablets.com/forum/topic/tethered-twrp-clean-root-exfatntfs-support-for-hi12/page/2/

For me the tethered boot did not work (probably the known HDMI problem, I did not have a cable to test), but flashing through fastboot worked fine.

After this I installed CM12.1, the Hi12 patches and GApps. Screen rotation works aain finally! WiFi is perfect, touch sensitivity is usable (but far from good, comparable to the original Android)

Thanks to all the hackers on this!

Simon

Link to comment
Share on other sites

Hello Konsta,

I've followed your guide with my Chuwi Hibook Pro.

I've managed to install twrp 3020 and boot to twrp already. However, when I try to install zip file, for e.g recovery-twrp-3.0.2-0-cht_cr_mrd_w-HibookPro, it says Failed to mount '/data' (Invalid argument) (the installation completed but it cannot mount the Internal storage I think). In the Mount option in Twrp , the Internal Storage is listed as 0MB.

Also, in the mount option, only System, Cache and MicroSD are mountable. Data cannot be mounted. And Data is ext4 with 0MB Size (in Wipe option)

Is it possible to fix this or revert it back to stock ROM? Since at the moment, it won't boot to the stock ROM anymore, the windows OS is still working I think.

Thanks a lot

Edited by examateur
Link to comment
Share on other sites

2 hours ago, examateur said:

Hello Konsta,

I've followed your guide with my Chuwi Hibook Pro.

I've managed to install twrp 3020 and boot to twrp already. However, when I try to install zip file, for e.g recovery-twrp-3.0.2-0-cht_cr_mrd_w-HibookPro, it says Failed to mount '/data' (Invalid argument) (the installation completed but it cannot mount the Internal storage I think). In the Mount option in Twrp , the Internal Storage is listed as 0MB.

Also, in the mount option, only System, Cache and MicroSD are mountable. Data cannot be mounted. And Data is ext4 with 0MB Size (in Wipe option)

Is it possible to fix this or revert it back to stock ROM? Since at the moment, it won't boot to the stock ROM anymore, the windows OS is still working I think.

Thanks a lot

Have you encrypted your device? You need to format /data partition in TWRP.

Link to comment
Share on other sites

13 minutes ago, KonstaT said:

Have you encrypted your device? You need to format /data partition in TWRP.

I have only flash twrp recovery and nothing more. So I have to wipe to factory setting in Wipe option ? If not, would you mind telling me how to format /data partition?

 

Update: I've tried to factory reset it in TWRP, but it said "Could not mount /data and unable to find crypto footer." and keep failing to mount /data

Edited by examateur
Link to comment
Share on other sites

1 minute ago, examateur said:

I have only flash twrp recovery and nothing more. So I have to wipe to factory setting in Wipe option ? If not, would you mind telling me how to format /data partition?

wipe -> advanced wipe -> wipe /data

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.