Jump to content

Possible Honor 8 Hardbrick

Guest newsupast

Recommended Posts

Guest newsupast

Hey there Guys, first of all thanks for takeing the time and reading through this post.

I have used the search function on this board and on google to an unhealthy extend the last 5 Days because no matter what i try there is always something in the way of every method i have tried to the extend that i almost accept the fact that my phone might be Hardbricked in terms of internal memory.

So lets get on with some data.

Im using the Honor 8 FRD-L09 with currently no OS whatsoever.
The Device is:
-Fully Unlocked (Bootloader, OEM, FRP, Debugging Mode (Enabled before Brick)

I Bricked my Honor 8 when i tried to use the Backup function of TWRP to later change the OS from EMUI 5 to AICP
The first try to change to AICP failed, saying for whatever reason that i cannot install this Update on a EVA-L09 Device, (which is strange since the Phone clearly says FRD-L09 on the back aswell as responding good to all past upgrades that i did , which were all for FRD-L09), so i chose to rollback to the Backup, however the Backup was corrupted in the process somehow and so the phone is currently without any OS as i couldnt reinstall the original Backup.

Ok so now for stuff i have tried and the errors i recieve while doing that.

After ERecovery is connected to any WIFI it spits out the error that no Packages can be found.

Fastboot Flashing
I have tried to install the Stock EMUI 4 Boot.img and then use the Huawei Update Extractor to extract the files from the UPPDATE.APP after i made sure that i have the correct firmware downloaded (The oldest possible, FRD-L09C432B101).
I can flash the boot and recovery images just fine, but the System and Cust images throw me the following errors:

System.img Error


fastboot flash system SYSTEM.img
target reported max download size of 471859200 bytes
sending sparse 'system' (427769 KB)...
OKAY [  9.631s]
writing 'system'...
FAILED (remote: sparse flash write failure)
finished. total time: 9.666s

Cust.img Error


flash cust CUST.img

target reported max download size of 471859200 bytes
sending 'cust' (416830 KB)...
OKAY [  8.920s]
writing 'cust'...
FAILED (remote: partition error)
finished. total time: 11.151s

I have furthermore tested all other FRD-L09 Firmwares up to 130 and even the new B320 for EMUI 5 (for which i installed the EMUI 5 Boot.img) aswell as trying to use:

ZIP Flashing
I have tried to use the following command:
fastboot flash zip UPDATE.APP , which spits out the following error:

[HIDE]fastboot flash zip UPDATE.APP
target reported max download size of 471859200 bytes
sending 'zip' (81444 KB)...
OKAY [  1.746s]
writing 'zip'...
FAILED (remote: Command not allowed)
finished. total time: 1.761s[/HIDE]

I have then tried to lock and unlock the OEM to fix the Command not allowed issue which however did not work out.

MicroSD Updating
I have tried the method of using a MicroSD to install the above Update.APP's in a dload folder in the Root of the card with the stock recovery, however no matter what firmware or what Boot.img or what Stock Recovery.img i use, i always get the Software Incompatibility error.

TWRP Direct Recovery and ADB Sideloading
I have tried the method of directly installing or Sideloading the files through ADB with the help of TWRP, but i get the errors that either /data or /system or /internalstorage cannot be mounted.
I have tried the solution suggested on a few promising youtube videos to simply try a combination of formating to a different type and then back aswell as repairing and then trying again, which worked for /system and /internalstorage, but /data is still not able to mount.

So as you can see i have pretty much tried every trick in the book to get my Phone unbricked, however non of those methods work and im getting desperate.
If any of you have more ideas as to what i could try, please post them here.

Link to comment
Share on other sites

  • 2 months later...
Guest juanboja

Hi newsupast,

I had the exact same problem you have, but in my Honor 8 FRD-L04. After many tries I finally solved it, and I hope it helps you.

Use the packages for the FRD-L09 version from this post https://forum.xda-developers.com/sho...84&postcount=2 were they have the Rollback package and the Firmware. Rollback your phone with your version packages. Hope this helps you because it made my life miserable for 2 days straight!! Let me know you it goes for you. Good luck.

Edited by juanboja
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.