Jump to content

Acer Liquid Z630S stuck


Guest Kumaranil_1918
 Share

Recommended Posts

Guest Kumaranil_1918

Hi,

I tried to root my phone using TWRP, ADB & Fastboot but my phone is stuck in boot. It restarts as soon as the Acer logo is displayed. Then, I tried flashing the Stock ROM for my phone using SP-Flash-Tool-v5.1532.00. I tried selecting 'Download and System.img' in the tool but it showed an error "Please select a ROM first". I selected Recovery. Flashing showed error. Then I selected system.img and Boot. An error was displayed. Then again, I selected System.img,boot,recovery. Flashing was successful but my phone didn't boot.

Then, I tried Firmware upgrade option but an error was displayed by the tool. At last, I selected 'Download only' option with (lk, boot, recovery, logo, secro, system). Flashing showed download OK. I disconnected the USB. Tried switching on my phone. I pressed the power button. My phone vibrated but the screen is blank.

My phone now vibrates then pauses for 7sec then vibrates again. The screen is blank all the time. I tried removing the battery and power on with battery but still the phone vibrates, pauses for 7sec and vibrates again. No display. Now what shall I do?

My phone details are below :

Model Number: T04
Android version: 5.1
Kernel version: 3.10.65
Image version: Acer_AV0L0_T04_RV01RC07_IND_GEN1
Build Number : Acer_AV0L0_T04_1 .007.00_IND_GEN1

Thanks.

1.PNG

2.PNG

3.PNG

Link to comment
Share on other sites

  • 3 months later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.