Sign in to follow this  
Followers 0
Tyler Doyle

Omnia II Will Not Charge

3 posts in this topic

My Omnia 2 will not charge. I've tried different chargers and different batteries, however it will still not charge. The phone its self will work with a charged battery, however it will not charge the battery.

I'm not sure what to do, perhaps I could get the charger port replaced?

Any help would be nice, thanks.

0

Share this post


Link to post
Share on other sites

I think you are right. Your charging port must be damaged. Get it changed. smile.gif

0

Share this post


Link to post
Share on other sites

hi there, i had this problem about a week ago. At first my O2 did charge trough usb cable (in my car and on my laptop).

When i left for a trip using the gps, i've got the message the battery was low, and so i noticed the battery was empty. Very strange. Even when in used it with the 12v-usb adapter it didn't charge.

At first i couldn't figure out why it wasn't charging anymore. Then i remembered i changed a setting in the usb-connection, under mass storage i've changed from "memorycard" to "my storage" so when i went back to "memorycard" it did charge again through the usb-connection.

Hope this can help you.

/edit : now i see your talking about chargers, i guess you mean wallchargers. Then probably this won't help you. But it's worth a try.

Edited by 6p4ck
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.