Jump to content

ZTE Blade 2 / Crescent - Crescent.MoDaCo.com

Discuss issues specific to the ZTE Blade 2 / Crescent in here. This device is also known as the Orange San Francisco II and the T-Mobile Vivacity.


680 topics in this forum

  1. Screen sometimes unresponsive from lock

    • 4 replies
    • 968 views
  2. Needing a flashlight app!!!(led)

    • 2 replies
    • 1.7k views
  3. Best A2SD method?

    • 24 replies
    • 6.5k views
    • 8 replies
    • 3.4k views
  4. QPST won't add Diagnostic Port???

    • 7 replies
    • 19.2k views
  5. capacitive key issues in any CM version

    • 3 replies
    • 869 views
  6. How to unlock and install a new ROM in Vivacity?

    • 1 reply
    • 2.5k views
  7. Raised corner of the screen

    • 5 replies
    • 875 views
  8. T-Mobile Vivacity is now only £49.99 payg

    • 13 replies
    • 3.4k views
  9. Phone Constantly Rebooting Itself 1 2

    • 39 replies
    • 4.1k views
  10. 67yr old suffering brain overload!!

    • 9 replies
    • 1.5k views
  11. Bit of help with TPT's and Roms

    • 3 replies
    • 1.3k views
  12. Old CWM backups not restoring

    • 1 reply
    • 1.1k views
  13. [ROM] Lewa OS [15/06]

    • 10 replies
    • 5.4k views
    • 6 replies
    • 1.4k views
  14. Fastest ROM for ZTE Crescent?

    • 10 replies
    • 3.9k views
  15. ICS Contacts on GB

    • 5 replies
    • 1.4k views
  16. Default Orange Signal Boost App 1 2

    • 27 replies
    • 9.6k views
  17. Sim / Network Unlock Files

    • 1 reply
    • 1.3k views
  18. TMV boots into FTM instead of Recovery

    • 2 replies
    • 1.4k views
  19. Looking For The TMV Unlock Zip

    • 0 replies
    • 875 views
    • 10 replies
    • 5.1k views
  20. Boot loop completely out of nowhere

    • 8 replies
    • 1.8k views
  21. Stock orange - google skymaps

    • 1 reply
    • 798 views
  22. Speaker not working on San Franciso II

    • 4 replies
    • 1.4k views
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.