Jump to content
tillaz

[ROM] FusionX Huawei Y300 v1.0 [B199] [Full HWA]

Recommended Posts

hey is there any way to get nova launcher.....instead of apex!!!!

 

just install nova and uninstall apex

 

Thank you fonz93, but will data be lost after wipe?

Share this post


Link to post
Share on other sites

Thank you fonz93, but will data be lost after wipe?

 

No, your data remains. You just need to wipe cache/dalvik cache. The next boot takes a little longer because the dalvik cache has to be created again but your data is still there.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks again :)

Can you help me please? I restart in recovery mode and later? Have I to flash directly the zip file or it must be extracted before?

Share this post


Link to post
Share on other sites

Thanks again :)

Can you help me please? I restart in recovery mode and later? Have I to flash directly the zip file or it must be extracted before?

Flash it directly and then wipe dalvic cache and cache (if you are on TWRP it will be shown right after flashing the zip ;) )

Edited by MasterRck

Share this post


Link to post
Share on other sites

Has anyone encountered an error while trying to change the Voicemail number and if so what was the solution as I can't currently listen to voice mails as its inputted an incorrect number and won't allow me to change it.

Share this post


Link to post
Share on other sites

Back to fusion again :D all i miss about cm Roms is the wifi strenght and stability, my router is a lil far from me so i get a weak wifi signal and my wifi disconnects more often , it wasn't like this in cm10, is there a way to make it better like in cm roms ?? Like copying some libs from cm roms or so ?? Or its more complicated

Share this post


Link to post
Share on other sites

i solved your same issues with it, so i dont know how to help you, maybe you can create an spn-conf.xml file to override the spn name

 

 

FOR ALL USERS:

 

Maybe this can really work, i patched services.jar and now systemUI.apk isnt in the background app list, so i think cant be killed (then no black screen and fix no status bar), for who want to try it here the link: https://www.dropbox.com/s/k3zodpp8dvvmsfc/services.zip

 

wipe dalvik and cache after flash pls

 

If that actually fixes it then there's a way to keep com.android.nfc too as it's a string array.

 

Here's a patch doing just that: http://ubuntuone.com/2vGwIXaTTsUdkmZlxxMC2K

 

It's untested since I don't own the Y300.

Share this post


Link to post
Share on other sites
If that actually fixes it then there's a way to keep com.android.nfc too as it's a string array. Here's a patch doing just that: http://ubuntuone.com/2vGwIXaTTsUdkmZlxxMC2K It's untested since I don't own the Y300.
Thanks, do you know if it is possible also to lock phone.apk?because when i tried to lock both, systemui and phone.apk, only one was locked, the other not, maybe i did some errors Edited by fonz93

Share this post


Link to post
Share on other sites

I'll double check things when I'm at my main PC shortly. At a glance the smali looked correct, but I'll convert it back to java to compare.

 

EDIT:

The codes right.

private String[] mAppToSetPersAdjArrays = { "com.android.nfc", "com.android.systemui", "com.android.phone" };

So use the first patch and instead try adding this to build.prop.

sys.keep_app_1=com.android.phone

You could also try this from command prompt:

adb shell
busybox renice -18 `busybox pidof com.android.phone`
Edited by H3ROS

Share this post


Link to post
Share on other sites

I'll double check things when I'm at my main PC shortly. At a glance the smali looked correct, but I'll convert it back to java to compare.

Ok thanks

Share this post


Link to post
Share on other sites
Guest

Back to fusion again :D all i miss about cm Roms is the wifi strenght and stability, my router is a lil far from me so i get a weak wifi signal and my wifi disconnects more often , it wasn't like this in cm10, is there a way to make it better like in cm roms ?? Like copying some libs from cm roms or so ?? Or its more complicated

+1!

Share this post


Link to post
Share on other sites

"Unfortunately, Contacts has stopped."

Happens every time I try to create an event (Birthday) on a new, or existing contact.

 

Worth noting that some pre-existing contacts (imported from Google cloud) do have Birthday events, so the error is likely emanating from the gui component for entering dates.

 

it's an almost fresh install of the rom, and happens on both of my G510s.

 

Any idea what might be causing it? solution?

Edited by TehJumpingJawa

Share this post


Link to post
Share on other sites

Hi,

Thanks a lot for this great ROM !

 

But I've a problem...

I think default SD (sd0) is internal phone memory ->1Go

If I put external SD, the default name of this card is SD1. Correct ?

 

The problem is the system think SD0 is like an external memory and some programs don't correctly work (example : TomTom).

How to define SD1 (real external memory) is principal SD ?

 

Can you help me ?

Thank you !

 

 

EDIT : RESOLVED !

I've make a new full install, but before format all SD with CWM.

Edited by Le Dam

Share this post


Link to post
Share on other sites

 

I'll double check things when I'm at my main PC shortly. At a glance the smali looked correct, but I'll convert it back to java to compare.

 

EDIT:

The codes right.

private String[] mAppToSetPersAdjArrays = { "com.android.nfc", "com.android.systemui", "com.android.phone" };

So use the first patch and instead try adding this to build.prop.

sys.keep_app_1=com.android.phone

You could also try this from command prompt:

adb shell
busybox renice -18 `busybox pidof com.android.phone`

 

to add this: private String[] mAppToSetPersAdjArrays = { "com.android.nfc", "com.android.systemui", "com.android.phone" };

 

i have to delete all .line 326?

Edited by fonz93

Share this post


Link to post
Share on other sites

i solved your same issues with it, so i dont know how to help you, maybe you can create an spn-conf.xml file to override the spn name

 

 

FOR ALL USERS:

 

Maybe this can really work, i patched services.jar and now systemUI.apk isnt in the background app list, so i think cant be killed (then no black screen and fix no status bar), for who want to try it here the link: https://www.dropbox.com/s/k3zodpp8dvvmsfc/services.zip

 

wipe dalvik and cache after flash pls

 

Thank you! Your trick works! :D Black screen problem is finally solved :)

Share this post


Link to post
Share on other sites

Guys i flashed this rom and suddenly i cant use any phone data, other than that the phone works great also my apn list is empty.... there is a lil R floating around my signal bars and internet ain't working.

Anyone got a fix for it?

Share this post


Link to post
Share on other sites

Guys i flashed this rom and suddenly i cant use any phone data, other than that the phone works great also my apn list is empty.... there is a lil R floating around my signal bars and internet ain't working.

Anyone got a fix for it?

where are you from? it seems that your phone work only on 2g network because you are in roaming (but you aren't really) and in roaming phone data are disabled for default.

 

Try to flash this https://mega.co.nz/#!4txUQLiK!B0BHtENu0nY-5Dw2L4G8jz6Wr6A-YLGfRJj1lxQi1uI

 

with this your network should be recognized as normal network and not roaming, so phone data and 3g should work

Edited by fonz93

Share this post


Link to post
Share on other sites

where are you from? it seems that your phone work only on 2g network because you are in roaming (but you aren't really) and in roaming phone data are disabled for default.

 

Try to flash this https://mega.co.nz/#!4txUQLiK!B0BHtENu0nY-5Dw2L4G8jz6Wr6A-YLGfRJj1lxQi1uI

 

with this your network should be recognized as normal network and not roaming, so phone data and 3g should work

I am from the Netherlands (dutch) using the carrier Tele2. I will try that once i get the phone in my hands it's from my mother. Other than that problem this rom boosted her phone alooottt it is just amazing.

Share this post


Link to post
Share on other sites
Someone have tested the Dalvik and Bionic from CM 10 on this ROM?
Does some improvement?

Share this post


Link to post
Share on other sites

where are you from? it seems that your phone work only on 2g network because you are in roaming (but you aren't really) and in roaming phone data are disabled for default.

 

Try to flash this https://mega.co.nz/#!4txUQLiK!B0BHtENu0nY-5Dw2L4G8jz6Wr6A-YLGfRJj1lxQi1uI

 

with this your network should be recognized as normal network and not roaming, so phone data and 3g should work

I tried it and still it's showing roaming so i still dont have 3g nor network. What i did was put the file on sd card and flash with recovery, then reboot. I saw same thing so went into setting checked for apn and added tele2 apn and still same problem.

Share this post


Link to post
Share on other sites

I tried it and still it's showing roaming so i still dont have 3g nor network. What i did was put the file on sd card and flash with recovery, then reboot. I saw same thing so went into setting checked for apn and added tele2 apn and still same problem.

So i dont know how to help you :(, sorry

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.