Jump to content

[STOPPED] CyanogenMod Beta2 Omnia 2 (updated: 04.05.2012)


Guest voyteckst
 Share

Recommended Posts

Hey. I am not expert in Android. I instaled it but I don't have my contacts from sim card. It is normal?

this happened to me too, but after i fully format my Internal and SD Card,.. i finally get my contacts fro SIM,.

Link to comment
Share on other sites

A quick update,

Installed Manually CM and all the recent updates to MyStorage.

Successful installation, all updates work fine.

Many thanks to the Devs team.

I am now going to monitor the Battery Charging and Drainage

I will report back.

By The Way, Guys, what is the best Email Client to use.

The one that came with Beta3 wasn't very good. It was

basic.

Link to comment
Share on other sites

... skip...

By The Way, Guys, what is the best Email Client to use.

The one that came with Beta3 wasn't very good. It was

basic.

k9 on app mkt

Edited by Job21
Link to comment
Share on other sites

Hello to everyone.

First of all I would like to say a big Thanks to the DEV team and VOYTECKST for this amazing work.

I finally installed the new beta in my storage using autoinstaller and following the instructions in the ''read me'' file.

I was stuck like others at the '' android to omnia II loading..'' booting screen and that is what i did (thanks to previous posts):

1st : I erased the ''block/'' word from the command line in the ''startup.txt'' file on the root of my storage and

2nd: I had to rewrite the ''vmalloc=256M'' command in the ''startup.txt'' file allthrough it was allready written by the autoinstaller. I erased it and wrote it again.

(I don't know why, but after this it worked!!!) so the new command line in startup.txt is now :

Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init console=ttySAC2,115200 vmalloc=256M"

My omnia 2 is the 8GB version and I made the 3 partitions (fat32,ext4,swap) to my storage manually with mini tool partition wizard.

Hope I helped ;)

Link to comment
Share on other sites

yes, screenshots here :D

ps: i agree with you that a new thread should be started every time a new beta released

post-700111-0-76891300-1322728264_thumb.

post-700111-0-45036900-1322728335_thumb.

Still cannot show chinese font after using the updated with chinese font. Do this related to the language setting. My setting is English (singapore) but there is no problem on beta 3 before. grateful if you can help.

Link to comment
Share on other sites

Still cannot show chinese font after using the updated with chinese font. Do this related to the language setting. My setting is English (singapore) but there is no problem on beta 3 before. grateful if you can help.

choos t. Chi. Or s. chi pls
Link to comment
Share on other sites

Still cannot show chinese font after using the updated with chinese font. Do this related to the language setting. My setting is English (singapore) but there is no problem on beta 3 before. grateful if you can help.

just now i switched to English (singapore) and it worked fine to display Chinese fonts

did your chinese fonts are 口口 or ??

if they are 口口,maybe you should make the permission of DroidSansFallback.ttf to be all checked

if the file in storage can't display chinese(??), you should change this line

"mount vfat /dev/block/mmcblk1p5 /storage" to "mount vfat /dev/block/mmcblk1p5 /storage -o iocharset=utf8" in init.rc using resco explorer,then reboot your phone

Link to comment
Share on other sites

hi everyone,

i have instaled manualy in my storage, and everything is just fine, but i have only one problem... my sdcard is set as my storage... and i cant see the files in sdcard, just the files that are in my storage, what can i do?

Is a problem with init.rc file?

thanks a lot for everything!!!!

Link to comment
Share on other sites

Hello to everyone.

First of all I would like to say a big Thanks to the DEV team and VOYTECKST for this amazing work.

I finally installed the new beta in my storage using autoinstaller and following the instructions in the ''read me'' file.

I was stuck like others at the '' android to omnia II loading..'' booting screen and that is what i did (thanks to previous posts):

1st : I erased the ''block/'' word from the command line in the ''startup.txt'' file on the root of my storage and

2nd: I had to rewrite the ''vmalloc=256M'' command in the ''startup.txt'' file allthrough it was allready written by the autoinstaller. I erased it and wrote it again.

(I don't know why, but after this it worked!!!) so the new command line in startup.txt is now :

Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init console=ttySAC2,115200 vmalloc=256M"

My omnia 2 is the 8GB version and I made the 3 partitions (fat32,ext4,swap) to my storage manually with mini tool partition wizard.

Hope I helped ;)

hey thnx for all dis... im having prob in androidinstall....when i click it it stucks at searching fat32 and shuts down... so culd u tell how u did d 1st install

i made all partns correctly fat32 ext4 n linux swap... also renamed sd.cpio.gz still fali... any correctn needed?

Edited by Abhiraj4
Link to comment
Share on other sites

k9 on app mkt

Thanks for the quick response,

I tried K9 Mail, It seems to be overwhelming with all

kinds of settings.

Sometimes it can be unstable, for example if you

have a POP3 mailbox and you have old messages in it

if you config K9 to retreive messages from say the

last 3 days, sometimes it doesn't listen and retrieves

everything.

May be it is more stable under CM

Link to comment
Share on other sites

我把andorid的时区设置成了+8,WM也是+8,可是每次进入andorid时间总比WM慢8小时。怎么才能让他们的时间一样?谢谢

I andorid time zone set to +8, WM is +8, but each time into andorid WM slower than 8 hours. How to make themthe same time? Thank you

Link to comment
Share on other sites

hi everyone,

i have instaled manualy in my storage, and everything is just fine, but i have only one problem... my sdcard is set as my storage... and i cant see the files in sdcard, just the files that are in my storage, what can i do?

Is a problem with init.rc file?

thanks a lot for everything!!!!

Yes, indeed. This must be the problem in init.rc. I had it before.Try to figure out the correct naming of devices in your case and modify init.rc accordingly. The simplest is to cd to the /dev/block directory while being in Android.

Sorry, in my case I had to modify vold.fstab to get correct mounting of SD card.

Edited by lemalin
Link to comment
Share on other sites

It works. I put it in/out and still detected.

Guess i have no choice but to format / reinstall then.

**

Trying to reinstall and i get : Couldnt find valid filesystem superblock while trying to open /dev/block/mmcblk0p and then it says End ? and hangs on the question mark.

I am using auto installer.

***

I found the solution to the problem, i had to rebuild the master boot record. Just saying in case someone has the same problem.

Edited by marios32
Link to comment
Share on other sites

first of all i'd like to say thaaaaaaaaaaaaaaaaaanks to every developer spent his time to bring this to us>>>> :-)

my experience:

- installed on internal storage.

- best performance till now.

- best graphic performance till now.

- arabic problem solved. :-) ;-)

- wifi didn't work at first but it worked later , i didn't know the reason just 'unable to scan'.

- i missed old lock screen look and fonts :-s.

i wonder what is remaining to be the stable release

Link to comment
Share on other sites

Yes, indeed. This must be the problem in init.rc. I had it before.Try to figure out the correct naming of devices in your case and modify init.rc accordingly. The simplest is to cd to the /dev/block directory while being in Android.

Sorry, in my case I had to modify vold.fstab to get correct mounting of SD card.

how can i cd while in android? rootexplorer can do it?

thanks a lot for your answer.

Link to comment
Share on other sites

Some personal updates :

I dropped the SD Card installation and I switched to My Storage (Internal SD) installation.

First I manually created the necessary partitions with Minitool Partition Wizard :

1. Connected the Phone to my PC with phone USB Setting to Mass Storage -- > My Storage

2. Deleted all existing partitions on My Storage

3. Created 3 partitions : one EXT4 Partition / Primary of 1088 MB size ; one Linux Swap / Primary of 288 MB size and one FAT32 / Primary using the remaining size

Applied same tactic on the External SD Card on which I created only one FAT32 / Primary partition of all Card's size

Copied the installer package on My Storage, renamed the file as described in the README notes (I think it was step 3b)

To be remembered : my EXT4 partition was the FIRST partition on my internal storage (My Storage)!

I installed the Android following the steps described in the README file.

After install, I got stuck at the "Android on Omnia 2 Loading..." screen, so I removed battery and restarted in WinMO.There I edited the startup.txt file on MY STORAGE and replace the corresponding existing line with this :

Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p1 init=/init console=ttySAC2,115200 vmalloc=256M"

The parameter mmcblk1p1 refers to:

blk1 - points to My Storage location (that's why 1)

p1 - points to EXT4 partition (that's why 1 --- the EXT4 partition was the FIRST partition on My Storage)

For example, if you install on My Storage and the EXT4 partition is your SECOND partition after using Minitool, then the parameter will be : mmcblk1p2

Everything works like a charm now except for the Camera ( NOT WORKING WHATSOEVER! ), everything is really FAST and had no issues at all!

Also the battery seems to hold up quite fine!

And, as I said, ALL Services and Functions work even better than they were supposed to....except for the Camera!

From my point of view, if the Camera issue is solved then THIS IS IT : THE NEW OMNIA 2 brought back to life!

Thanks Devs and thanks DJHOULIO for his explanation of the startup.txt mods!

EDIT : forgot to mention - the whole installation process was done WITH the SD Card attached in the phone! Also, my phone has the JJ1 ROM installed, no other mod applied!

Edited by Vlad_O2_RO
Link to comment
Share on other sites

how can i cd while in android? rootexplorer can do it?

thanks a lot for your answer.

I did it using terminal emulator installed from Market.

FYI. My setting in vold.fstab is

dev_mount sdcard /mnt/sdcard auto /devices/platform/s3c-sdhci.0/mmc_host/mmc0

Link to comment
Share on other sites

I did it using terminal emulator installed from Market.

FYI. My setting in vold.fstab is

dev_mount sdcard /mnt/sdcard auto /devices/platform/s3c-sdhci.0/mmc_host/mmc0

is you sdcard as 0p ???

Link to comment
Share on other sites

my experience is focusing on extendig battery duration....

w8 any mail clietn and automatic switch (2' connection every 15' on with sreen on) the duratuion is VERY good.. as soon as i install any mail client the duration drops drmatically.. seems that any mail clinet drian battery even whe no connection is available... any tips is welcome ;)

Link to comment
Share on other sites

Hello to everyone.

First of all I would like to say a big Thanks to the DEV team and VOYTECKST for this amazing work.

I finally installed the new beta in my storage using autoinstaller and following the instructions in the ''read me'' file.

I was stuck like others at the '' android to omnia II loading..'' booting screen and that is what i did (thanks to previous posts):

1st : I erased the ''block/'' word from the command line in the ''startup.txt'' file on the root of my storage and

2nd: I had to rewrite the ''vmalloc=256M'' command in the ''startup.txt'' file allthrough it was allready written by the autoinstaller. I erased it and wrote it again.

(I don't know why, but after this it worked!!!) so the new command line in startup.txt is now :

Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init console=ttySAC2,115200 vmalloc=256M"

My omnia 2 is the 8GB version and I made the 3 partitions (fat32,ext4,swap) to my storage manually with mini tool partition wizard.

Hope I helped ;)

how did you check that vmalloc was at 256M ? did you go in terminal emulator and type free?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.