Jump to content

[DEV][ROM][24.01.14] CyanogenMod 11 (Android 4.4.2)

Guest gbosh

Recommended Posts

This is my port of CyanogenMod 11 for ZTE Crescent. It is unofficial and unsupported by the CyanogenMod team. It's for developers/testers/advanced users only.





GAPPS https://docs.google.com/file/d/0B_f-rFtMJSdjdVJfdlJka1M3Vkk/edit

(thanks to the Thor)

  • RIL (mobile network & data)
  • Wifi
  • GPS
  • Audio (playback/input/routing/headphones/etc)
  • Camera (photos & panorama)
  • Hardware acceleration and OpenGL rendering
  • Hardware video decoding & encoding
  • 'Project Butter'
  • SD card
  • USB-storage (on external sdcard) & adb
  • USB-tethering
  • Wifi-tethering
  • Touchscreen/multi-touch
  • Sensors
  • LEDs
Not working:
  • Camera flash
  • Front camera
  • Bluetooth isn't working properly
  • FM radio, as always works,but only trough spirit FM
  • ART
  • Wifi tethering ( use an external app )
  • Video recording works, but not in stock camera app


  • Installation instructions
  • Download ROM, Gapps to your SD card
  •      Boot into clockworkmod
  •      Backup your current ROM (optional but highly recommended)
  •      Wipe Data / factory reset
  •      Advanced / Wipe dalvik cache
  •      Mounts & Storage / format system & boot (just to be sure)
  •      Install zip from SD card - choose ROM zip
  •      Install zip from SD card - choose Gapps zip
  •      Reboot




  • CyanogenMod team & everyone who's been working on CM11
  • Dazzozo
  • KonstaT
  • tilal6991
  • fagyi,zeelog and probably many others
Edited by gbosh
Link to comment
Share on other sites

Guest dodgetimmy

Thanks gbosh! So with gaps you need a 220mb partition?


I have a SF2, but what about Vivacity users like yourself? There are no links of any TPT's over 200mb system.


Jeez only 996 kb free without gapps on a 200mb system partition :D

Edited by dodgetimmy
Link to comment
Share on other sites

I still have the 220mb stock partition layout, because I've never done anything with tpt.

But as it seem, all dl links for 220mb p736e partitions are dead, so I'm gonna have a look at that soon and see how that whole thing works

Link to comment
Share on other sites

Guest dodgetimmy

Well I've had a play with this rom, at first I installed on a 200mb system then installed the gapp .apks after extracting them from the zip file as user apps. This caused a problem with force closes, so just going to stick to flashing the zip in CWM with a 220mb system partition.


The kernel in this rom is the original overclock kernel, is it possible to add newest kernel as well as overclocking?


Bugs for me:


* Touch screen calibration is off, always pointing half a finger to the right of where you press. This seems most apparent on the right of the screen.

* There is a bizarre, but quiet humming sound after the keypress sounds, but not on every part of the rom, it happens in the settings menu and in some apps. Almost sounds like interference or a hard drive hum lol

* There are force closes when trying to enter storage in the settings menu and also developer tools in the developer menu.

* When connecting to a computer through USB file transfer, the phone takes an abnormal amount of time to finish loading the connected or not connected screen. Instead the refresh circle goes on for about a minute.

* I installed Gapps and they appear to just fit on a 220mb partition but only with 49kb free. I'm not certain this is enough free space. To add to this, the start-up wizard didn't work on first install, so perhaps it hasn't installed correctly because of lack of room?

*Internet works fine but cannot sign into my google account, error message comes up "there was a problem communicating with google servers. Try again later" Nevermind, google trouble server wide: http://www.google.com/appsstatus

Edit 2# It seems the problem is not related to google servers being down, but instead is another bug, perhaps related to a 220mb system partition not being enough room for gapps and the rom together.


I hope I can add more feedback when I have used it more. But thanks again for this brilliant rom :D

Edited by dodgetimmy
Link to comment
Share on other sites

Guest Cuvillier
I also have a bug in the ROM otherwise it is very fast: 
when I want to edit an image gallery, it's a crash after a few seconds. I hope there will be a fix in the next update gbosh,Thanks !
Edited by Cuvillier
Link to comment
Share on other sites

Guest Typhus_

This is cool.




Hey, how about building a new recovery as well?


I mean, since you do have the skills to sync sources and build stuff, why not build a new CWM Recovery as well? I'm trying to do it but, up until now, my efforts didn't provide any satisfactory result.


Keep it up.

Edited by Typhus_
Link to comment
Share on other sites

Guest reedo_17

Nice to see this. Will try soon!

Also as Typhus_ says an updated recovery would be a good thing!

Furthermore I remember seeing that some CM11 roms required anupdated CWM recovery to function properly, is there any reason for this?

Good Work gbosh

Link to comment
Share on other sites

Gbosh are you planning to build SlimKat rom? Yesterday I install TPT (250/150/?) and CM11. after few apps installed my phone runs out of memory.

I think slimkat is our best chance, or triminng CM11.

Link to comment
Share on other sites

Guest Antiseptic

Thank you so much for this! I will gladly test this and report what I find. I have vivacity (telenor touch plus), touch screen works fine, no problems there. Definitely need to use tpt otherwise there is no Play store, so I have to flash again. I also hear that humming sound after pressing something. When I go to settings - storage it suddenly crashes . What amazed me is how fast this rom is. Seriously, it's very fast, no lag or anything which is great and thank you again for making this. I will later add play store and try with some memory scripts so I will edit with more information. Edit: I couldn't find any tpt for Vivacity with more than 200mb system (I already have that) so I managed to flash google play by trimming down the rom (deleted everything I didn't need) so now everything is working ok. I couldn't just install google play apk like the previous user because it crashes. Int2ext doesn't work, I tried two and nothing. Also, when installing any app from play store, downloaded app crushes. I tried app2sd and similar and it reports couldn't move to sd. I don't know if it's a problem with memory or some bug. But I suspect it's memory problem because I tried some apps from apk files and everything is fine. If anyone has a link for Vivacity tpt with more than 200mb system that would be great.

Edited by Antiseptic
Link to comment
Share on other sites

Guest relaxpn

Thanks gbosh for this, as Antiseptic said, it's super fast, no crashes so far, will know about the battery drain in 2-3 days I guess.

It couldn't fit on a 200mb system partition, so I had to trim it down a bit, now everything is working.

Btw, int2ext+ works fine with this ROM.

Link to comment
Share on other sites

Guest dodgetimmy

The problem with making a TPT is hex editing. You have to edit the hex values of one or two files. Amphoras did it a while ago and created some TPT's and a TPT helper application on the market.


The problem is, I think the app was created first for the original blade. When I try using it I can't use it to create my own TPT. Just pressing the option doesn't do anything. I haven't tried any of the standard TPTs and have always installed them manually on my P736V


Anyway, for the P736E users, have you tried TPT helper to see if it has any 220mb system TPT's?


I guess the easiest path to creating a TPT with more system space would be just to copy these P736V ones some how? I wonder if its possible. 

Edited by dodgetimmy
Link to comment
Share on other sites

I'm pretty sure, using this tutorial http://www.modaco.com/topic/354290-how-tosave-your-dead-vivacity/

will take you back to stock tpt. or just updating trough ZTE's official tool, here http://download.ztedevices.com/UploadFiles/product/643/2614/soft/P020121010608886762774.zip

I have however not tried it myself.

Edited by gbosh
Link to comment
Share on other sites

Guest dodgetimmy

If you can get into fastboot and have working drivers yeah.


But then if you wanted CWM recovery you would need the recovery.img and have to flash it via fastboot as well?

Edited by dodgetimmy
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.