Jump to content

Coolpad F1 8297w - Review / Info / Software / Custom Roms

Guest dakok

Recommended Posts

Guest Destiny133

There are a lot of phones in that range and not all phones are same so its tough to recommend


Xiaomi got new policy, and that is unlocking bootloader now takes 720 hours so vendors dont replace it with fake rom and fake UBL and then sell it

Some phones have anti rollback protection

Which means you cant downgrade to certain level unless you make small modification, but there are few topics for every phone which removes ARB trigger script


I own redmi note 5 ai, device is awesome

And yes my phone did came with anti 4

But it doesnt stop me from flashing roms onto it, its quite easy, just need extra few steps

Link to comment
Share on other sites

  • 11 months later...
On 6/15/2018 at 10:48 AM, Jpower73 said:
ATOMIC OS for Coolpad F1/Micromax A310/Himax Polymer Octa by Jpower73




1. Status bar :-
Statusbar Items
Quick Settings
Clock and Battery Adjustment
Carrier Label

2. Navigation
Navigation bar [DUI]
Button Settings

3. Lockscreen
Lockscreen Shortcuts
Double tap to sleep anywhere
Lock screen torch
Power Menu (Lock screen)

4. Panels
Recent Panel[Immersive Recents]

What’s Working:-
Weird Sounds After Flashing Gapps Fixed
Adaptive brightness
Phone FC Fixed
Camera (Stock Camera) + Video Recording (Except Stock Camera) Working Perfectly
No Need To Reboot For Apps To Appear In-App Drawer
Hotspot Fixed
BT Fixed
Data Working
1080p Playback In Gallery Fixed
Youtube 720p Fixed,1080p too
Youtube Live Playback Fixed
Solid explore file manager added
Titanium backup added
No Sim Fixed
No Network Drop Found
USSD Fixed
Auto rotation Fixed
Substratum support(no need to reboot to apply theme)
FM Radio in Earphones
After Reboot Quick Settings Too
Rest Are As Nougat
Too Many Features

Bugs :-
VPN (Use ShadowRock App : NAT Mode. Do not let playstore update the apk)
Video Recording In Stock Camera ( Use Footej App or Cameringo. Both included)

Credits :- 
Aditya Kumar
Teja K
Aokp Os Team
Neeraj Thakur
Sartaj Prince
Kishan P Patel
Yashpal Joshi
Sooraj Suresh Kichu
Shubham Verma
Anupam Anand


ROM: https://mega.nz/#!RRQFAQrb!06HBDBtLGwNGymLP-dqtoLyUSFT_a740IfmYyU0onlU

Xposed Framework: ---No Need to flash. Just connect to the internet, open up xposted installer,wait few secs, tap on Version 89 button once appearing. It will dl & install the appropriate framework. It will Reboot.

(Zram pre-activated, gapps pre-installed)

Wipe data, cache, dalvik-cache, system.
Flash ROM.zip


Does anyone here still use Coolpad F1? and/or above ROM?

I've found two bugs while using the ROM above that I haven't found earlied:

- only one SIM card works and I can't get 2nd one to work or at least getting recognised (tel says there's no SIM card in slot), even after exchanging SIM card places, it still says that the same slot doesn't have any card (there's visible one or the other card, depends on which slot it's put in).

- it doesn't recognise BT SmartBands around but BT works with other devices - tried few of them from different brands (C1s, M3, Xiaomi Mi Band 3 & 4) and none of them are visible. I don't believe that's limitation of the chip not supporting BLE or newer BT versions, as I have other phones on MT6580/6582/6592 with Android versions from 4.2.2 to 7.1 and these phones see all these bands.

Did anyone had such issues or has any workarounds/fixes?

The most important for me is the BT here as I wanted to monitor my daughter's moves & condition using any of the bands that I have around, but I'd like to avoid changing ROM / cleanup everything as besides these two bugs I find it the best working & smoothest I saw so far on F1.

Edit: OK, I've found that when I enable BT & location in power save mode and leave both enabled, then make phone reboot, then for short time after reboot BT works fine and discovers all devices nearby, so I was able to configure the app for smartband for continous connection.

It worked good enough that it made smartband firmware upgrade (it took more than 10 minutes, but it didn't drop connection and upgrade was successful).

After that smartband rebooted and phone didn't re-establish connection again (I had to reboot the phone again). After phone has booted, it worked again and so far works, but I know I can't touch BT or location settings in phone, because it will stop working again until next reboot.

Did anyone found something like that? and/or solution for it?

Edited by xeros2
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.