Jump to content

[HOW TO] Use Xposed Framework 2.6+ on Huawei ROMs


Recommended Posts

Guest fonz93

With a proper build.prop editor:

 

Find this line: ro.config.hwtheme=1 (or 2, it depends on your device)

 

Change to: ro.config.hwtheme=0

 

This will disable Huawei Theme Engine

 

 

WITH THIS YOU DON'T NEED TO DISABLE RESOURCE HOOKS

 

 

Enjoy new Xposed Framework

Edited by fonz93
Link to post
Share on other sites
Guest Naikkon

amd if you find this Build.prop [8 lines under ro.config.hwtheme] search for: ro.config.hw_battery_percent and change from false to "true" for % on battery [ use Rootbrowser]

Link to post
Share on other sites
Guest SaurabhRCk

When I install xposed in stock huawei rom having emotion ui theme, the icons set to default after activating xposed! will this solve the problem?? I don't really understand whats the need of this! 

Link to post
Share on other sites
Guest fonz93

When I install xposed in stock huawei rom having emotion ui theme, the icons set to default after activating xposed! will this solve the problem?? I don't really understand whats the need of this!

This is needed to disable huawei theme engine or xposed 2.6+ will not work

Link to post
Share on other sites
  • 1 month later...
Guest fonz93

I'm using Emotion UI and it goes back to ro.config.hwtheme=1 after I change it with Build Prop Editor

 

I think your build.prop editor doesn't have RW permissions, try another app

Link to post
Share on other sites
  • 5 months later...
Guest clickmeplz

With a proper build.prop editor:

 

Find this line: ro.config.hwtheme=1 (or 2, it depends on your device)

 

Change to: ro.config.hwtheme=0

 

This will disable Huawei Theme Engine

 

 

WITH THIS YOU DON'T NEED TO DISABLE RESOURCE HOOKS

 

 

Enjoy new Xposed Framework

 

This way does not work with EmotionUI 2.3

The only way for enabling xposed is xposed "settings->disable resource hooks". This way enable xposed but even i could not run gravity box (for example) under xposed. it raises error again.

Edited by clickmeplz
Link to post
Share on other sites

This way does not work with EmotionUI 2.3

The only way for enabling xposed is xposed "settings->disable resource hooks". This way enable xposed but even i could not run gravity box (for example) under xposed. it raises error again.

 

EmotionUI 2.3 is not officially released for us, the framework of that version of EmotionUI should have a similar prop

Edited by fonz93
Link to post
Share on other sites
  • 9 months later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.