• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

[GUIDE 2.0] Ascend Y300-100 (B182) Bootloader unlock, TWRP, Root, Custom ROM flash

15 posts in this topic

Posted

Hey guys,

 

I just wanted to make a slightly more updated and easier guide, as a follow up to this extremely helpful guide written here by tooplanx, and sourcing many of the same sources, but also some crucial new ones. I particularly spent hours looking up how to install the latest software (recovery and ROM), when in the end the solution was simple but not widely known and very noob-friendly. Here goes...

 

1) 1. First I downloaded drivers for the y300 from here: https://files.dc-unl...BE98BC29A9C1216

 

Extract the drivers and launch 'DriverSetup.exe'

83.png

 

Wait for this to install fully.

 

2) Next, go into your phone settings and turn off 'fast boot'. Turn off your phone and remove the battery for 5 seconds. Replace battery, and press vol + and - repeatedly and the power button for several seconds, until screen goes a violet colour.

Now connect your phone to your computer via USB and wait for the drivers to install fully.

 

3) Once your phone is connected, load up dc-unlocker. In the 'Select Manufacturer' box change it to 'Huawei phones'. Leave everything else as it is (including the 'select model' box).

 

Click on the large magnifying glass button. This will scan the phone for its bootloader code and show the unlock code required after around 10 seconds.

 

Copy and paste the 16 digit "Bootloader code" somewhere safe (like a notepad file).

 

Close the dc-unlocker, turn off your phone (you may need to remove the battery), and unplug from the computer. Reboot your phone.

 

WARNING- THE NEXT STEPS WILL FACTORY RESET YOUR PHONE: IF YOU NEED TO BACK UP ANYTHING, DO SO NOW!

 

ALSO: New(er - explain in a bit) files for the following located here: https://www.dropbox.com/s/336npm7l2xb8b1b/Y300-AiO-ROOT-v1.5.zip

 

4) I then followed Step 2-4 from this webpage: http://huawei-y300.t...ascend-y300-all

 

At step 2.11 of the website instructions, when running 'unlock_bootloader.bat', type in the 16 digit unlock code generated by dc-unlockerFollow the remaining steps to the very end... the SuperUser part is very important, and flashing the recovery is need to do this).

 

5) You should now have a fully rooted phone, with a recovery option to go. Now, if you want the latest and best, it may be advised to get a very recent ROM. However, to upgrade past Android 4.2 you're going to need the latest TWRP recovery to flash it - and doing this is easy. Just download the image file here (or search your device for later versions on the site), stick it on your SD card/phone memory. and head to the Play market. Search and download for Flashify - install it and launch.

 

6) Grant Flashify SU access when the prompt comes up. Select "Recovery Image" and locate the image you downloaded and moved to your storage earlier. Flash it.

 

7) Download your ROM. There's a whole list of suitable ROMs for the Y300 here; find the thread that suits you and go to it. Read what it says, any particular notes and what others say on the release.

 

I chose CyanogenMod 10.2 by Dazzozo since I thought 11 probably still isn't stable enough, and if you go to the download link on that thread you'll notice he's been continually updating his release since he launched that thread. My thoughts on it all later... but important to note, I used TWRP to flash it, not ClockworkMod like this thread suggests should be used.

 

---- AT THIS POINT: ------ Be cautious about following my steps. What worked for me may not work straight for your ROM, though I don't see why it shouldn't... someone else fill me in here?


8) Stick the ROM on your SD card. Also you'll need to download something called GAPPS (specific to the ROM you chose) if you choose a CyanogenMod ROM... this is because by default, Google apps are not included due to legality reasons. Click the link and locate the package applicable to your chosen ROM, then put that on your storage.

 

9) Boot into TWRP. Take your battery out for 5 secs, put it back in, power on and hold up volume until recovery boots.

 

10) Go to Wipe > Swipe to Factory Reset; Advanced Wipe > Check: Dalvik cache; Cache > Swipe to wipe

 

11) Go back to home. Do a backup and select all options > Swipe to backup.

12) Home > Install > (Select Rom) > Add more zips > (Select GAPPS file) > Swipe to confirm flash and wait till it's all done.

 

13) Reboot, hope it worked and just let it all load up. Hopefully you should be taken through set up and boom... you're done :)

 

Any problems, come here and I'm sure we'll be willing to help! Also, before going into complete panic like I almost did (didn't wipe stuff first time), breathe deep, take your battery out for 5+ seconds. Put it back in. Try boot into recovery again... as long as that works you are pretty darn safe.

 

My experience with Y300 and CM10.2:

 

Interesting. Considering this has gone through so many updates now it still feels very buggy; I get it is a nightly but it just feels slower on the resources - and this is exactly why I didn't want CM11 just yet. I think it is great you guys support our developers but I feel the phone is more sluggish than before I wiped it and programs close randomly at times. I think I would not have minded just having a new launcher like Apex put over the one Huawei provides and the default used Trebuchet launcher by CM didn't sit with me - but that is largely because it lacks a simple pinch to zoom function for the homepages which I find very important to me. 

 

If anyone else can weigh in on how I feel, add alternative suggestions (ROMs; launchers; ways to improve system resources) I would greatly appreciate it.

 

Hope this helps someone; thanks to tooplanx for making the effort extremely easier on my part, and all the original posters before him/her. At the end of the day, we're all littler people, standing on the shoulders of the giants before us.

 

Cheers ;)

 

 

 

0

Share this post


Link to post
Share on other sites

Posted

i have a question i choose the ROM , Huawei Ascend Y300-0100V100R001C00B194 V1.7(NovaLauncher) then what is the GAPPS of this rom? i dont any idea :\

0

Share this post


Link to post
Share on other sites

Posted

Ops , i think i did it . the huawei start up is appear :) and i hope it works. because i miss my phone :3 honestly my main problem is my phone stock because of installing chainfire3d, and this is what i use technique to make my phone work again.

0

Share this post


Link to post
Share on other sites

Posted

hi there im new to rooting phones etc but followed this guide to the tee. but seemed to be having trouble getting any rom to work i wipe cache etc and install zip and all is installed good but when i reboot its just stuck on the huawei ascend screen and will not get past it. i have tried plenty of roms and all the same except the huawei ascend y300 stock rom that seems to flash fine and gets past the boot logo. im installing cyanogenmod 10.2 by dazzoo but like i said its stuck on boot screen. can anyone offer any help as to why this is happening the recovery twrp 2.6 i have tried to flash 2.7 but says failed.

0

Share this post


Link to post
Share on other sites

Posted

Wipe everything except SD cards and flash the ROM ;)

0

Share this post


Link to post
Share on other sites

Posted

If anyone else can weigh in on how I feel, add alternative suggestions (ROMs; launchers; ways to improve system resources) I would greatly appreciate it.

Try with Nova launcher if you dont want to change CM 10.2. SlimKat is better then CM 10.2 so try SlimKat.

i have a question i choose the ROM , Huawei Ascend Y300-0100V100R001C00B194 V1.7(NovaLauncher) then what is the GAPPS of this rom? i dont any idea :\

If you use stock or stock based ROMs then you dont need gapps, because gapps are included. If you use other ROMs (like CM) then you need different Gapps. If you use CM 10 then you need JellyBean 4.1 gapps, CM 10.1> JellyBean 4.2, CM 10.2> JellyBean 4.3, CM 11> 4.4 gapps.

If you flash different gapps you will have crashes when phone start, also your keyboard will not appear.

Ops , i think i did it . the huawei start up is appear :) and i hope it works. because i miss my phone :3 honestly my main problem is my phone stock because of installing chainfire3d, and this is what i use technique to make my phone work again.

Try GLtools. I think it is better then chainfire3D.

0

Share this post


Link to post
Share on other sites

Posted

Thanks for doing an update, I'm aware that some of the steps I did might have become outdated and there are newer files available.

 

I managed to update to the latest TWRP after much struggles (everything said to use GooManager, which would never work).

 

I've now settled on SlimKat 6.2 (thinking about updating to 6.8 maybe). I find it to be the only ROM I've used on the y300 that gives adequate performance. The only downside I've got is that often images will not display properly in web browsers and other web-based apps, though I can just about live with this given the overall usability and stability of the ROM.

0

Share this post


Link to post
Share on other sites

Posted

Hi. I tried the guide but dc-unlcker unlock button is greyed out. I also tried force unlock but it says I do not have enough credits. Help me please.

p.s. It seems huawei no more offers on his site the form to obtain the codes.

0

Share this post


Link to post
Share on other sites

Posted

no one?

0

Share this post


Link to post
Share on other sites

Posted

up.

0

Share this post


Link to post
Share on other sites

Posted

ufff no one has my problem?

0

Share this post


Link to post
Share on other sites

Posted

My problem is My device stuck up to bootloop. I encountered this problem when I rooted it using RootMaster and install a SuperSU. I install another app named chainfire pro. The app ask me to reboot then I press OK after that my phone stucked up to Huawei LoGo. pls help me.

0

Share this post


Link to post
Share on other sites

Posted

Hi. I tried the guide but dc-unlcker unlock button is greyed out. I also tried force unlock but it says I do not have enough credits. Help me please.

p.s. It seems huawei no more offers on his site the form to obtain the codes.

http://en.club.vmall.com/emotiondownload.php?mod=unlock&action=pre

 

;)

0

Share this post


Link to post
Share on other sites

Posted

I'm stuck at using Flashify to install twrp 2.6.3

 

When I transfer the .img file to the phone, it lands at a file structure that looks like:

 

Alarms

Android 

App 

Baidu

 

etc.

 

But when I explore the phone's file structure with Flashify, I think I'm at root access, which is a maze of twisty passages, all alike, none of which lead me to my twrp .img file:

 

.cust backup

acct

cache

config 

cust 

d

 

So I'm trying to find my .img file from this root directory and can't.  I realize this is a bonehead question, and apologize in advance.

0

Share this post


Link to post
Share on other sites

Posted

Ah, found it.  I think it was under /storage/sd0/

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.