Jump to content

MCR - MoDaCo.one for the HTC One S (Sense + Vanilla) new: WiFi Calling support

Recommended Posts

I just bought a T-mobile (USA) One S and imported to Australia. Managed to sim unlock and flash new bootloader. Then I flashed Ir3 Sense and all seems great!

Just having a problem getting the network data speeds I was expecting. I've tried all of the network providers and only Telstra gives me decent 3G data speeds. I've checked the other network providers frequencies, and the ONE S should be able to work on all the frequencies over here.

On the box for the One S, it lists the supported frequencies as GSM:850/900/1800/1900 UMTS: band I (2100) band II (1900) Band IV (1700/2100/AWS) Band V (850).

With Optus and Vodafone I get 2g shown in the notification bar. Telstra shows 4G and a quick test gave me 16Mbit download speed.

Is it likely that I need to flash a new baseband that will help with this problem? If so, how do I know which one to flash. I've done all sorts of rom flashing, but don't think I've done a baseband....not sure really!


current baseband 0.16.31501S.16_2_10.22.31501S.10L

Anyone advise?

Share this post

Link to post
Share on other sites

I just installed the Sense option w/o Wifi calling on my HTC One S (S4 T-Mobile UK). It all seems to be working okay but I have the 4G icon (don't really care about that) - more importantly, I have no wifi. MAC address shows as unavailable and Wifi option shows "Error". Should I have installed the Wifi calling ROM even though I'm not equipped to use it?

Update: Installed the Wifi calling ROM and have the same issue - Bluetooth still works but no Wifi radio. Previously was running stock with a fresh Superboot/root, this is the first ROM installation on this handset using ROM Manager. All data and caches cleared prior to installing - after root Wifi was working without a problem. Used this ROM as I wanted to try out Google Now, otherwise would have reverted back to stock.

Resolved: For the benefit of anyone else with the same issue, I followed the instructions here which worked perfectly.


No WiFi with MCR3.

Share this post

Link to post
Share on other sites

Hi Paul, kmow you must be busy .. do you have plans to update this to the 2.xx build that is being offered OTA?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.